Tree of Savior Forum

Known Issues - UPDATED (April 12th)


the best would be the actually make the servers do they’re job.

I’m hanging aroudn with 0/0 hp/sp since hours.
Can’t do my job change quest… duo drops not registering … nor mana pots usage. Server lag xD.

And my wiz i wanted to make, doesn’t even get Job Exp xD…

This is so much worse then icbt2.

And i don’t want to be that guy.

but i told people. That most were holdign back on purchases. That eu topic gave hope, so people bought in last minute. xD i saw that comming somehow… now one part is stuck at kaleipedia or orsha. As they used they’re fp benefits there. The other one couldnt login and went to fediman.

Time will fix it … maybe it’s simply to MANY people xD.
From the 16 hours i was awake. I had played 5? Spent most time in que’s, dc’s or trying to get my job change to work xD. Luckily i could do other things while waiting.

Half a book finished.
Figurine shelf built nearly.
And i even did clean my windows… which i do twice a year…
xD not complaining. But it’s always a surprise when people tell dev’s “there might be lots of more players when you carter to the rest too, more then you think.” … and then they go “WHOA where did these masses, that burnt our servers down come from!” xD…

This happened to often …


It’s about server lag.

Pots, Stats, Exp, Quests not applying.
Duo data getting lost… slowed down. Or never even created xD.

Too many watermelons trough only one little straw~


I cannot progress my quest as my character is stuck in a cinematic after defeating the Fire Lord in the quest (Into The Grip). I can get out by changing server but I can endlessly grind the reward, I guess. GG so much issues.

1 Like

To fix this do not defeat this boss with an ability. It has to be an auto attack. It worked for me.

so you guys are gonna put early Regional servers since bottlenecking occurs right!? :grinning:

player population increase is no surprise tho Steam users, Friends of some users playing this game and ofc those who don’t want to pre purchase / Day 1 buyers are sure to affect. you guys should have known better …

Please see these as well and try to fix it. Many of us are currently stuck in progression.


  1. Press F5 to go into quest log.
  2. Click “Abandoned”
  3. Click to get the quest again!!

There’s a wobbly head bug that I’ve encountered when you press, for example, W+A, you walk horizontally but the head will flip from the right position to another one over and over, making it all wobbly.

Others have the same issue. To me it doesn’t occur when I left click and walk around.



Several players haven’t received stat points while leveling. Relogging/changing channels does not make these stat points show up. I currently haven’t received a single stat point single hitting level 4 on all of my characters.

No responses as of yet, and would heavily appreciate someone addressing this:


I try first step about server list and it doesnt work to me =/ i want to play so much :frowning: help me pls…

Germany foxy. Germany.

1 Like

Please don’t release a game that doesn’t work for 5/10 people.


Pseudo transfer!


After collecting all the crystal energy from the quest Into The Grip you cannot turn in the quest anymore. Nice.

If you are playing on Klaipeda, it may be due to the lag. That being said however, could you give us some more details so we can check the logs?
For instance, team name, which server you are playing on and which map/zone you were at? Screenshots would also be appreciated.

unplayable with this lag, are u guys gonna open new server soon?

1 Like

Hey @STAFF_Ethan … I am very upset that does not allow transfer, after using the pack… I happy I contribute to the game, I expect the same of you as a team

Hello @gglopezo,

I did mention that we are considering such transfers in the future. :slight_smile:

Such full transfers require much more time when compared to item transfers so please bear with us.

1 Like

Staff help me pls, i dunno what is happenning with my game… i cant see ther servers… i close my anti-virus, i close my firewall
i tried everything… i deleted the client file and repair using steam tool…
and nothing… i need to help really

i can ping that server host… but in game it is empty still

hello… im just wondering why my 1 character cannot log in but the others can… and it says CommaderLoadFail… please fixed admin thanx

Team name: Apotheosis, character name Perfection. Playing on Klaipeda because I was told Orsha had all the BRs. I am in Ashaq Underground Prison F2. All the channels seem empty/fine but they’re still lagging bad.