Tree of Savior

Official Client Shutdown Information Gathering Thread


#1

Dear Saviors,

We would like to gather information that the users whom facing Crash issues with recent updates.

  1. World / Team Name

  2. Computer Speculation -
    CPU
    GPU
    RAM
    HDD/SDD << where you installed ToS!!

  3. Last action you conducted and the Map location. - Klaipeda? Orsha? Saalus? (and possible, with the Screen Shots)

Bad example - I was just playing << please share me with more details, There are many codes and stuffs inside of game and it really matters what you did before the crash

Good example - I was in Klaipeda X channel, I opened the Inventory and got crashed + screenshot

The dev could expect that Klaipeda, of course the villeage has many objects to create, and plus with Item inventory
Maybe the dev could find where is this memory rise is coming from.

Well I’m not really well understanding the entire system but as close one, this could be the thing

  1. Are you using Any kind of Add-ons? If so what are you using right now?

  2. How Frequently you face Crash issue? (ex, I face Crash every X times in an Hour)

I will keep on eye on this thread to keep sending reports to the Devs.
I hope we could fix this soon… since we expect updates coming up again.


My game client error and close
#2

#3

Hi Yuri. Thanks for this.
We already sent tickets [me,megamanex14,Rxlxk, others] answering all this needed info.


Please check our inquiries. Thanks again for this.


My game is crashing
#4

Hey,

1: Teamname: Saintshadow Character Name: Alatariel

2: CPU Intel Core I7-8700K ~3,7 GHZ 12 CPUs
GPU MSI 1060 6GB
RAM 32 GB Ram Corsair - Not sure about the speed but it was rather a faster one.
SDD 1TB Samsung SSD 960 PRO

3b: I was letting my computer running twice over the night in order to gather PP Points. I was standing in Fedimian while doing so. Sometime during the night my client did shut down. When I checked my char the next morning I noticed the issue.

3a: I was playing League of Legends while ToS was ruinning in the background. I switched between ToS and LoL with Alt+Tab a few times while playing. Randomly it crashed there too.

4: Addons:

  • Chat Macro Save
  • Chatextends
  • Extended UI
  • Easy Mount
  • F**K Pets
  • Indun V2 Plus
  • Zoomy Plus
  • Turi of Savior
  • Map Mate
  • Hide Name
  • Bookmark Warp
  • Easy Search
  • Buff Helper
  • Auto save money

5: I do not face many crashes. Only had about 5-10 ones so far during about 1-1,5 weeks.


#5

#6
  1. Telsiai/Aknel
  2. Computer Speculation -
    CPU = Intel Core i3 4160 @ 3.60GHz
    GPU = 4096MB ATI AMD Radeon R9 380 Series (Gigabyte)
    RAM = 12.0GB Dual-Channel DDR3 @ 798MHz (10-10-10-30)
    HDD/SDD = (E drive) 931GB Hitachi HDS721010CLA632 (SATA)
  3. Last action you conducted and the Map location.
    90% during warping, 10% random. Usually occur after accessing world map, using warp statue, using warp scroll, interacting with same npc more than 2 times. Symptom before crash occurred: white world map, extra slot in inventory UI despite no item is showing. Picture can be seen from Heavenpiercer’s post Bugs after 2018 oct 30 patch and oct 31 maintenance
  4. NO Add-On
  5. Every map and every channel, every time using statue warp, every time using scroll warp.

Welp… Another waiting week then.


#7

Hiya Yuri!

  1. Fedimian / Gernst

  2. CPU: Quad Core i5-4460 3200Mhz
    GPU: Nvidia GTX 750Ti 2 GB GDDR5
    RAM: 8 GB DDR3 1600Mhz
    HDD: Seagate 1TB 7200rpm 16MB cache

  • Getting buffs and repairs on channel 4 or 3 or 2 or 1 then going to the statue to travel to Saalus or Lanko Waters or Astral
  • Farming mats on Barynwell Waters 85 than using Klaipeda scroll to go back to the city than to the Lodge
  1. No addons are used

  2. Cannot complete my daily three Saalus without getting loading map freeze once

I would like to report hereby things that might help the devs get closer to the cause of our problem:

  • I get VGA errors and loading screen freezes time to time, usually when jumping from channels to channels in Saalus to Klaipeda or the opposite. I dont really recall getting VGA error just by trying to open Inventory

  • Inventory acts wierd everytime i use repairs, and repairs only, no problem with Armor Maintenance and Enchanting. Here is a video how it looks like:
    https://youtu.be/nfQxQkWo7d8
    After just opening Repair shop window inventory gets full of these squares, i know those are empty spaces. When de-equiping an armor piece that has a similar type in my invetory, equiping it again generates a “shadow” square in the same line. If i dont have a similar equipment in my inventory this wont happen. Also changing channel, reloging, opening repair again resets inventory back to before and shadow squares are gone. Just by rearrangig inventory via Order by function generates the same bug. Closing inventory is not helping.

  • About loading screen freeze: EVERYTIME when world map becomes a white mess after the first or second try of loading new map, the loading screen freezes ALWAYS in the middle

  • Everytime when changing a channel, the first time opening inventory seems to take more time than usual, especially if i am in Klaipeda ch1

Thanks for opening an official thread for us to report our problem, that was really needed. Many of us tried to send a ticket about this matter and been waiting for some good news or some delightful response, just by opening this very thread is something like that.
And i would like to share that i can see Devs are did a good job, because, i dont know about others, but i dont get VGA errors as often as before the maintenance, so they sure are doing their best to find the cause of this issue.


#8
  1. Klaipeda / Devarc
  2. CPU i7-7700HQ 2.80GHz
    NVidea GTX 1050 6GB
    16GB ram

HDD Seagate 1TB

  1. Anywhere, sometimes selecting a character and I’ll get VGA error and instant close, sometimes I don’t even get to the character selection screen, I sent more information + videos and screenshots through tickets days ago but got no reply, so resent again.

  2. no addons, freshly installed ToS 4-5 times

  3. everytime I open the client under a minute after selecting character or at the lodge it just kicks me off


#9

Not sure if this have to do something with the issue. But everytime when I start the game and I login a new char. I have a kind of strange laag. Sounds will make buggy noises and I got a strong freeze for about 3-5 seconds. But once it loaded completely I got no more issue - also when I change chars everything is fine.

Edit: Ups I wanted to make a general reply to this topic - not to your post Heavenpiercer - Sorry


#10
  1. Klaipeda / NGEvangelion
  2. CPU - Intel Core i3-4150 CPU @ 3.50GHz
    GPU - Intel HD Graphics 4400
    RAM - 8.0 GB
    HDD/SDD - Seagate Samsung Spinpoint M8 SATA HDD 5,400RPM - OS (C:) 919.10 GB Available
  3. Klaipeda Ch 5 Opening up the inventory, talking to Storage, Market, Instanced Dungeon, Event NPCs, talking to Warp Statue or trying to teleport to a different location, changing channels, or just walking around the city will trigger the error.
  4. Uninstalled all addons so I currently run the game with no addons.
  5. I face the crash every time I perform an action stated in #3. Sometimes I can do two actions such as talking to two Event NPCs or opening the Market then Storage for example, but then the game will crash after that. Sometimes the game crashes after the character selection screen when trying to load into town. Crash occurs in Klaipeda and Fedimian. Not tested in Orsha or other maps.
  6. Other things to note: I run the game at low settings

#12

I hope for those like me that is been almost 2 weeks that can’t even log in we gets all events extented and a hugeeeee Compensation for this lol.


#13

honestly hope so like seriously, 4 velcoffers/4et daily raids, heck we even missed the new raid that came out last week and ppl making bank from recipes that dropped there that right there is a huge down for me tbh, could’ve made a bunch of cash and not to mention black butler outfit like gg bank + my token expired and got no cash cause all cash is in teamstorage


#14

Yeah, my token has been wasting away these past two weeks and other items are expiring because I haven’t been able to play and haven’t really been able to participate in the new events. Need an extension on all of these things.


#15

I agree but I wonder how are people are still able to play the game and we can’t.They did 2 patches and still can’t fix it next week will be the third attempt and the second week


#16

gonna be the third week for me bruh, idk about you haven’t been able to since last october patch just hope they fix it I’m getting tired crawling on forums and tickets to see if there’s a resolve


#17
  1. Klaipeda/Narcissus (character Eostre)
  2. i7-7700k, 4.2 GHz
    Nvidia GTX 650 Ti
    32 GB RAM
    Samsung SSD
  3. Crashed in all 3 runs of the Castle (300) Dungeon running someone through it on my wugu falc, in the same room: Where the first real device is that opens the boss room on the SW side. Hitting the device isn’t what caused the crash, but any time I would drop wugushi poison on the ground in the room, the poison would flash white and the game would crash–but only in that room.

Also my hawk is invisible.


#18

Other Companions can get invisible too. Furthermore the moon from the event gets invisible sometimes.


#19

Sorry for taking time on creating this thread, we we’re explaining about the situation after the patch and waiting in our system to clear out the old logs so we could create a new.

I’m sending info gathered today, until this reply


#20

Great patch my buddy @STAFF_Yuri you are closing some of the events that we miss out on…very nice man…good job IMC!

And on the patch there is nothing mentioning fixing this problem so guys we have to wait for another week which would make my third week I can’t log on TOS… IMC is doing great…I wonder how is Lost Ark doing XD.


#21
  1. Klaipeda/Vylet {character name: Maybe(thaum3linker3sorc)}
  2. Computer Speculation -
    CPU - Intel R Celeron R N3060 1.60ghz
    GPU - Intel R HD graphics 400
    RAM - 4gb
    Toshiba 1tb
  3. Last action you conducted and the Map location. - Spell tome Map; Every time I warp to spelltome on any channel I get half way loading screen and the client shuts down. Also I have noticed that on my task manager tos client has a note “TODO” on it with some Korean writing. It seems like the problem is only for intel users my Desktop which is amd is totally fine.
    On my laptop at first, I cannot load tos client it self I had to reinstall the whole thing including reinstalling steam. Finally, after that the client loads up after 1min of waiting then I get vga error while loading into Klaipeda map on any channel it gets half way through loading screen on any of my alts then the client will shut down but after trying 1-2x more it successfully loaded up. Went to saalus map,fedi map it was fine but after doing all my dailies I warped my thaum3linker3 alt name “Maybe” on spell tome I get the half way loading then the client will close it self actually any of my alt that will go to spell tome map gets half way loading screen and the client closes up.ss
    Also another thing I’ve noticed is when I use statue to warp on maps the world map has no background it was just white.
  4. Are you using Any kind of Add-ons? If so what are you using right now?
  • No, I don’t have any addons the files were freshly downloaded
  1. How Frequently you face Crash issue?
    -Every time I warp any of my alt in spell tome map on any channel
  • Gets vga error on main towns esp. Klaipeda (have to try loading in for 2 times until it loads successfully).