Tree of Savior

How to Change to Korean


#1

Hi guys since i just starting playing on the steam
do you know where i can get the korean text or at least write in korean on steam TOS. saw someone using korean char name, asked him but his afk ㅠㅠ


#2
  1. I think this thread belongs in the help desk to be honest.

You only need to be able to input Hangul characters on the language settings. Copy / Pasting may work but I’ve never tried. I’m going to assume that you have the Korean language pack installed in your operating system, you can find some guides on how to change it.

http://windows.microsoft.com/en-gb/windows7/add-or-change-an-input-language

And then, have fun


#3

sorry if i put it where it doesnt belong
ofc its not that easy… if that work i wont ask here… even if i put copy paste the character would come up as question mark {???}
and if i change the language option on the game to KR would be some note note note something
is there maybe anyone have the korean language pack in their TOS folder?


#4

What a horrible, typical reply to a very good question.
“This looks like it belongs in the help desk…” ??? If you don’t have anything useful to say, don’t say it. Or admit you don’t know, jesus the community of ToS sometimes…

No answers to these questions. There are about 5-6 of these questions that have just been ignored by everyone.


#5

This is the Translations section of the forum, and the thread itself is asking for something else - hence the statement in the first place. It will be less visible to others since it has been posted in this section and the purpose and desire of the OP don’t match the purpose of the category it has been posted in.

I don’t want to sound rude or anything, but it says Here about what is to be discussed in such topics - with a sub-category discussing english localization of the game.

This particular question that is asked isn’t something that a majority of players would solve or have interest in solving, this is the international Tree of Savior, English being a primary language to use would mean that typing input in Hangul is not at all required.

You don’t need a Korean version of windows in order to type in Korean, also after looking through your other short posts you seem to be considering that there are some secret files that let you input in Korean, this is not the case either.

Unless i’m misunderstood and she wants to play the game with the client in full KR(Ui,Quest,text info etc.) then i don’t think it’s actually possible with how the file reads data text line numbers having variations in each region, it would be better to just play kTOS entirely.

Well, if you can describe what methods you may have explored perhaps an alternate path can be recommended. I’ll talk briefly about how mine appears to work.


A first method is to ensure that your system locale is (KR), this can be done by navigating through ' Control Panel > Clock, Language, and Region > Region and Language' this then opens a pop-up window, go to the ’ Administrative ’ tab and select the button saying 'Change System Locale' and then select Korean (Korea) from the drop-down menu and select OK, this will most likely result in your computer requesting a restart too, so you will want to do that.

Here is a picture of what it should be on a windows 7 operating system, with red lines indicating things to look out for.

after your reboot, ensure your keyboard is able to swap between languages, you should have something at the bottom right of your task bar saying something like EN or something denoting an abbreviated country language (EN,CN,JP etc).

If you right click that it will open a mini-menu and you’ll want to click settings to open up the input languages window, it should look like this:

if Korean is not on the list, you need to click Add and find Korean option that’s in the next window that opens briefly, not sure if it asks to download language packs here either, but it shouldn’t if you already have it installed. After that you can confirm it and click OK, after ensuring it’s on the list we can close this window.

This step is sometimes where person’s get lost, you can now shift language from EN to KR by pressingALT+Shift at the same time, this will cycle through your list of input languages. It should change just like the image below indicates. If the combination of keys doesn’t work, you should check what the key sequence is by navigating to the Advanced Key Settings in the input languages tab, i’d recommend to set some if there isn’t any already to at least shuffle between languages.

If it has done that, then you are on the right tracks.

You cannot immediately type in Korean, even though it has been changed to the KR input. “but why?!?!” - this is because there is a setting to swap between inputting in Hangul and English characters. If you press ’ALT GR' on your keyboard it will swap inputs allowing you to type entirely in Hangul characters, if you need to use English characters again you can press ALT GR and return to English characters.

When the change is occurring you can identify what you will be typing in.
(A) = English
(가) = 한글

Hopefully after understanding all of this, it shall work for us. We open our ToS clients now and press enter to prepare to type, use those hotkeys that have been mentioned before (Shift+alt), (Alt+GR) to obtain your desired input, your input should now be able to properly toggle between eng and kr.

If you’re still having some issues with getting it to work, well we’ll have to see what can be done about it. But if i did offend you with my first reply, i’d reccomend to see if the members that work on the Support Desk can help you out, you can send in a support inquiry here, and if it comes to that maybe they can help you out: https://treeofsavior.com/inquiry/ :slight_smile:


:cherry_blossom: [Guide] jTOS or how to [RESOLVE] most of your issues with iTOS.:cherry_blossom:
1st JTOS thread
#6

@Gwenyth
Thanks for the thoughtful reply. Best help I’ve seen yet in the year that these questions have been floating around.
You should be proud of yourself.

That being said, the only thing I have tried thus far, is exactly what you recommend in your screen shots.

I have swapped the Windows 7 version to be set in Korea (Region setting), and changed the language/format to Korean, as well as added the Korean keyboard and IME.

No luck on this having an effect on the Korean language selection in game. It still shows up as a bunch of random characters.

I just feel like since there is literally an option to switch to Korean language in-game, maybe it was a feature that was meant to work.

I have submitted a support ticket, but god knows how long that will take for them to tell me that they dont know either lol!


#7

Do you mean stuff like:
ҾҪЀѶ (or even generally English looking letters with accents on them)
and just general characters like that?
I think that might require you to re-install your game client to fix that issue, but i do have another potential resolution.

Inside your options when selecting the keyboard, ensure that the ‘Microsoft IME’ is the only option ticked under the Korean (Korea) Keyboard, apparently having the first Korean option ticked causes the computer to become unable to input the keys entirely for some reason.


#8

Being able to type Korean in-game has nothing to do with having Korean texts for Quests/UIs/etc. You need a Korean language pack (pulled from Korean client) pharsed in a way how iToS client handles the language files. Luckily, you’re not the only person who’s trying to do this, and here’s a link to my work.
Btw, Korean client’s lines do not match with English client’s one to one, so there will be some English lines for certain NPCs.


#9

Old reply, but yes.
This is exactly how it looks when I try to type in Korean: ҾҪЀѶ

It is specific only to tree of savior. I am able to type in Korean perfectly fine in my internet browser or notepad. 봐. If it were as simple as installing korean keyboard anyone could do it.

I have tried to reacquire. Like OP said. Even Korean text that is COPY/PASTED is changed into these characters.

My issue, which was aside from OP’s, was that I wanted the game itself to show up as korean text. Which you promptly addressed as being impossible for some reason.

All I’m saying is, you typed a whole lot of stuff. But it was information everyone, even the OP who asked the question, already knew. And you walk away from the situation thinking you have solved the issue, when you merely half-assed understanding the problem, making it harder for someone with some actually helpful information to solve the issue.

You explain how to add korean keyboard, declare the issue resolved, and walk away. It’s like thowing salt onto a gangrene infested cut and declaring the person is healed.


#10

Yes, it may seem this way. All i can do is apologize to this person - my only defense itself is the system notification from the forum itself, mine is always broken and i don’t receive a lot of notification for a lot of reply/like etc.

I don’t really know what you would like for a response for this kind of message though, so i can only say that i am sorry for the scenario itself and lack of effective assist. I will have to be better to handle the situation :frowning:


#11

thanks! the instructions given are working. Now I can type in hangul.