Tree of Savior Forum

Can't use especial characters or symbol letters

I have a problem that occurs only on ToS. Every time I try to type characters like “Á”, “É”, “Ç”, it shows like a “.”. I wanna know how can I solve this problem. I found a few people with exactly the same problem: - The “layout” solved the problem for this guy but not for me
How to Change to Korean

Gonna reply here as the other topic is for the Portuguese translation project. Also, let’s see if you can be less aggressive with people who tries to help you.

Windows 10? Check this:

Did you try the basic stuff already? Update Visual Basic, removing addons specially the ones related to chat functionalities? Check game files through Steam and, as a last resort, remove the game (including game folder) and reinstall it again?

Now I trully think you do wanna help. Thank you for your effort. I went to your post 'cause I thought you may know this problem and its solution as you’re translating the entire game. Yes, I already did the basis, including uninstall the game to install it again as a clean version without any addon. I use Windows 10 Pro in my notebook and desktop. Now that you showed me this post, I think maybe it’s a problem related to this Windows. I never tried to play ToS on another Windows version. However it does not help me any further, since I use build 1903 - the most updated one. As for Visual Basic, I don’t think I have it installed. Isn’t this a program for programmers only? I don’t recall any game I play using this stuff, except for Counter-Strike and just if you wanna use wall-hack (I just know, I don’t use it). I will try to download this and see if it solves my problem.

**I don’t have any problem naming a new Character. The problem shows up just when I try to use especial characters, symbols, accent, etc.

It is actually the Visual C++ packages, they are needed for the game to run, and Visual Studio is the programming IDE, not this one. Check the ones you have installed, then update/install the ones you need. Check the “runtime error” section here, it gives you download links:

Personally, I go a little further here with my PC and install all the versions I can find in Microsoft website.

If that does not solve your problem, then I don’t know.

Nope. Nothing solved my problem. I quit. I appreciated your help though. Cya.