Tree of Savior Forum

Resolution for Skill_bytool Bug

After 12th episode update this week, some players are having error like this:bugtos

Cause: missing lastest ipf files: 278397_001001.ipf, 278538_001001.ipf and 278546_001001.ipf meanwhile release.revision.txt and skill_bytool are updated to the lastest changes already. Trying to copy these 3 ipf files into patch folder will not work. The patcher will detele them as soon as you launch the game.

Solution 1: Roll back to last week version

  • download these 2 files: release.revision.txt and skill_bytool.txt
  • go to Steam\steamapps\common\TreeOfSavior\release and paste (overwrite) 2 files above.
  • open game. At this moment, the launcher will start to download and apply patch for this week from begining. If the launcher shows patching error, open Task manager and find any running ToS process and kill it. Then follow step 1 again.

Solution 2: Fresh reinstallation

  • uninstall ToS from steam menu. Close steam client.
  • go to Steam\steamapps\common\TreeOfSavior and delete EVERYTHING inside. If there are some files you can’t delete (under using error), open Task manager and find if any process named ToS is running. Kill it and try to delete again
  • open steam client again and install the game.

Solution 3: Replacing game client

  • Since my game client is running perfectly, I have uploaded it to Onedrive so you can download and replace with your current client. Download from here. (~22.1Gb)
  • Close Steam client and go to Steam\steamapps\common\TreeOfSavior and delete 3 folders patch, data and release.
  • Extract the client file you have just downloaded, you will get another 3 folders patch, data and release. Copy it to Steam\steamapps\common\TreeOfSavior accordingly. Now open Steam and start the game.

Note:
- You should delete all 3rd addons before trying these solutions. You can install addons back again after the game can launch successfully.

Please let me know if this tip doesn’t help.

1 Like

i’ve tried both method it didn’t work…fresh installation result in the skill_bytool bugs…the 1st method didn’t do anything either it patch like usual only now it stuck on white page before it closed itself…i hope there’s other way thank you anyway

I am compressing and uploading my whole game client. Will update method 3 to replace the game client. :sad:

image

sorry for the trouble krystal if only imc can fix this bug themselves it would be much better

Nah I am glad to help. The game client is bugged, IMC needs to take a look later. Pretty sure if I reinstall the game, I will get the same error. For now we are gonna find a way to login and play first.

1 Like

i hope it’ll work this time…im kinda scared if they patch the game in the future same bugs occurred…hope they fix it then

Updated game client download link. Let’s give it a try. The game client is pretty huge thou.

Hello Krystal, first of all I’d like to thank you for taking your precious time helping me all along,

We did solution 1 and 2 but none of them worked, that’s before we actually get my windows 10 activated
So when I rebooted my pc and tried solution 1 again, this time around, the 3 files werent directly deleted once the launcher finished downloading it

So yes solution 1 worked for me. if anyone else has the same issue please try this out first.

Arigatou Krystal

dang 13gb…i have 100mb connection speed but the download speed i get is around 1.3mb~2.50mb RIP i tried leaving it overnight but i can’t resume it…it manages to download 11gb and just it when “you can’t resume your download homie” windows and their retarded apps…sigh nevertheless thank you krystal

at least your method work on him enjoy your games buddy ill join in later… :sob: :sob: :sob:

You can select individual folder to download separately. Download 3 folders at once may be too big and cause error. Try to download release first, then data then patch. :smiley:

@Krystal Yo krystal this solution works !! Thanks !

1 Like

i’ve download all 3 folder thanks heaven this time it download without a hiccup!!..im going to try the 3rd method and give you my feedback big thanks to you krystal!!..

1 Like