Tree of Savior

[GUIDE] Common Technical Fixes


#1

Hi, I recommend going through all these steps as they may solve the problem you’re having. This is far from in depth and is just a very basic starting place. I have roughly ranked the fixes from least to most difficult/obtrusive. I can’t guarantee a fix but feel free to post or PM me for any additional help with the solutions here. If there are any additional fixes, information, or suggestions please do post them here or PM me so I can add them to the list.

Content

1. Restart the Game
2. Disable Optimisation
3. Verify Integrity of Game Cache
4. Delete User Settings
5. Reinstall
6. Update Drivers
7. Turn Off Overclocks
8. Additional Information
9. Useful Links

1. Restart the Game

For any strange errors with UI or freezing or really anything else try restarting the game. Some issues are sporadic or a one off so restarting the game is the best way to continue playing.

2. Disable Optimisation

  1. Enter and Join the Game
  2. Access the Game Settings
  3. Uncheck Optimization (Beta)

Some computers may have difficulty with the Optimisation option. This is effective at dealing with gameplay, and loading crashes. Even with disabling the Optimisation option many of the improvements in performance will remain.

3. Verify Integrity of Game Cache

  1. Open Steam
  2. Go to the Library Tab
  3. Right-click on Tree of Savior in the list of games
  4. Select Properties from the list
  5. Select Local Files on the menu
  6. Verify Integrity of Game Cache

What this does is check for differences in your game files with the one Steam has on their servers. Any differences will corrected. This is especially useful for post maintenance problems.

4. Delete User Settings

  1. Navigate to the Tree of Savior directory
    For example: C:\Steam\steamapps\common\TreeOfSavior
  2. Enter release folder
  3. Delete user.xml and user_c.xml
  4. Restart Game

These are the files that store the in game options, as well as some other behind the scenes settings created by the game. Tree of Savior will recreate them on launch which allows for them to be reset.

5. Reinstall

  1. Open Steam
  2. Go to the Library Tab
  3. Right-click on Tree of Savior in the list of games
  4. Select Delete Local Content
  5. Select Delete on the Confirmation Box
  6. Select Install Button once the Game has been uninstalled and reinstall

There are many reasons why the game may have problems, by reinstalling any problematic files are replaced.

6. Update Drivers

Updating your drivers may help with graphical problems or crashes. Even if it doesn’t, it’s good to have your drivers updated anyway so go do it.

Links:

http://www.geforce.com/drivers - Nvidia Drivers
http://support.amd.com/en-us/download - AMD Drivers

7. Turn Off Overclocks

A recent driver change may have reduced the stability of your overclock, the game itself might not play nice with them, for whatever reason it could be worth turning them off to see if your error can be fixed.

8. Additional Information

  • Any TP related problems should be immediately reported via Support Ticket.

  • When looking for help clearly state what solutions you’ve already tried.

  • Disable all addons if you’re having trouble, especially after an update.

9. Useful Links

https://forum.treeofsavior.com/c/help - Link to relevant forum area

https://treeofsavior.com/page/support/ - Support tickets and FAQ

https://www.reddit.com/r/treeofsavior/ - Someone may have similar issues or offer additional help

Known Issues - UPDATED (April 12th) - Outdated but potentially useful information


Update 01/03/2017 Error: 147684_001001.pak Failed to download files
Game keep crashing since after today's maintenance
The .ipf files are damaged and cannot be read. the client will shutdown
#2

#3

Tried all of this and does not help. It says you are missing files and it will download them but it doesn’t apparently. Maybe you should post your .dll or some other common misplaced files somewhere so people can replace it manually.


#4

Have you tried reinstalling DirectX?:

https://www.microsoft.com/en-us/download/details.aspx?id=35&44F86079-8679-400C-BFF2-9CA5F2BCBDFC=1

Or what about reinstalling Microsoft Visual located here:

C:\Program Files (x86)\Steam\steamapps\common\TreeOfSavior\_CommonRedist\vcredist\2015

and running: vc_redist.x64.exe (and possibly): vc_redist.x86.exe

You may have to download them directly from the Microsoft website:

https://www.microsoft.com/en-us/download/details.aspx?id=53840


#5

It tells me I don’t have dsetup.dll file
None of my games have these problems for these files anyways
Why would I jeopardize messing with something I don’t really know about just because the devs don’t know how to send you complete files for the game.


#6

Generally that particular dll is a DirectX problem, I’ll upload them to Dropbox.

dsetup32.dll: https://www.dropbox.com/s/xyy6rn2glj5ehot/dsetup32.dll?dl=0

DSETUP.dll: https://www.dropbox.com/s/ycfisu1vh36de8p/DSETUP.dll?dl=0

You’ll want to place them in this location:

C:\Program Files (x86)\Steam\steamapps\common\TreeOfSavior\_CommonRedist\DirectX\Jun2010

If that doesn’t work, try placing them in:

C:\Program Files (x86)\Steam\steamapps\common\TreeOfSavior\release\patch\DirectX10

and launching from tos.exe located in:

C:\Program Files (x86)\Steam\steamapps\common\TreeOfSavior\release\patch

If that still doesn’t work, you may need to delete the .xml files located in:

C:\Program Files (x86)\Steam\steamapps\common\TreeOfSavior\release

and verifying once more, then launching from tos.exe

If it all possible, I do recommend trying to reinstall DirectX, either through the download link, or the DXSETUP.exe located in the DirectX folder.

It is frustrating unfortunately.


#7

I honestly think they should focus on problems with the game instead of constantly feeding players with items and new maps the existing players is what I hear.


#8

Part of the problem right now, is IMC is focusing on addressing old balance and content issues, and while they do fix bugs like this, it is slow. They’re not really wasting any time, I’m not sure what you mean about new maps, R9 will be coming out sometime this year, but it’s months away and new content is desperately needed.


#9

Hello i cannot play my TOS.Please help as it show "11135_001001.pak Failed to download files. This might be a communication problem. Please check your connectio and restart client. (824)

I have browse other solution and it still pop up the same thing.

Even i have try to uninstall and re-download back and it still the same.

Please assist on this as i have play 3 days without this problem after maintenance i am facing this problem.


#10

What’s the number inside release.revision.txt?

  • Example location: C:\Program Files (x86)\Steam\steamapps\common\TreeOfSavior\release

Try replacing the contents in there with: 187272

If that doesn’t work, try:

186893


Error :11135_001001.pak Failed to download files. This might be a communication problem. Please check your connection and restart client. (824)