Tree of Savior Forum

Game crash when changing / teleporting / warping / switching to any map

Please fill in as much as you can :

Date and Time(Please, specify the timezone) :

Server Name: Telsiai

Team Name: Grishaden

Character Name: Illviyuri

Bug Description :
Bug happened after logging in and changing map at least twice. Happened only after the update. Tried removing mount / companion & cupacabra. No effect.

Steps to reproduce the issue :

  1. Log in
  2. Teleport to any map
  3. Teleport to any other map
  4. Game freezes with bgm still playing but image is not responding

Game Control Mode (Keyboard/Joypad/Mouse) : joypad


  • CPU : i5 2nd Gen
  • RAM : 8gb
  • Graphics Card : GT640M
  • Mainboard :
  • Storage : 1TB HDD
  • OS : Windows 10
  • Internet Connection : 100 mbps
  • Country, Region : Malaysia
1 Like

Hello @caliraith,

For us to further assist you on the issue, please send us a ticket.

Assume so. tried redl and repatching same thing. Not sure wats going on. sent a ticket though see wat happens I guess

(post withdrawn by author, will be automatically deleted in 1 hour unless flagged)

Alright, did some testing.

I can open the game, choose a server and select a character without fail, upon doing this, a loadscreen will trigger and finish adequately, with me being able to play the game normally. However, any action undertaken that would trigger a loadscreen from this point will cause the game to hang indefinitely, with the background music still playing.
If you enter the game and gain control of your character, then go back to character select and try to play a different one, the game will hang right away. I assume that some weird interaction happens after you’ve selected a character, and from there on out, any attempt to enter a loadscreen will freeze your game.

Note: I keep mentioning loadscreens, but past the initial one that comes after selecting a character, no other loadscreen is allowed to initiate. Instead, the game freezes and stays like that indefinitely until I close it.


just to add on a bit. I also tested a bit with making another character. Seems to be all jolly and fine until i changed channels and the game died. So yea literally any sort of load screen will cause it to fail.

EDIT: So after doing a complete clean uninstall, deleting all folders from steamapps and redowloading on a seperate drive completely. Found out that even before installation the DX10 setup is broken and cannot install properly. Might mean there was a tampering or change of the resource for this. Not sure if that might help pinpoint the prob. Also now the game totally refuses to run at all. It just starts then closes

1 Like

Exactly this happens to me and I already send a ticket

it’s more now I do not open the game

Nothing bad happened to me today specifically, but some of my group partners crashed/dc’d while we were running dungeons. I cannot grant that it was because of this latest patch because if my memory is still ok it happened to me yesterday as well.

Few guildmates are reporting that they can’t change maps either on Klaipeda. Loading screen doesn’t go anywhere, and if I guild master summon them to a map, they black screen until they restart the game. Upon restarting, they will be on whatever map I summoned them to, but they cannot leave that map.

Also the VGAs are still going on. Literally everything is VGAing outside town, any time large amounts of skills are used. GTW and Boruta were basically unplayable, and even things like album events caused a ton of crashes. Certain bosses crashed every single person in range with a VGA. The phase change of Skiaclipse is another one, causes tons of VGAs.

@STAFF_Amy @STAFF_Bob @STAFF_Yuri Please address, the game is completely unplayable.


Not even town is safe…

Also just throwing this out there, have you considered proper error handling so that people can actually send you a meaningful file for what crashed them?

Right now you’re probably getting a ton of reports saying “it’s this armband!” and “it’s this headgear!” and “it’s X skill” or “it’s Y skill” and there’s not any kind of way to get the information as to the root cause.

Graphics should just never cause crashes, using a skill if the animation is missing or corrupted in some way, or there are bad interactions between graphics, it should just result in it showing some kind of default graphic/animation rather than causing a critical error to the client. Most people would probably be okay with giant purple cubes or red question marks if something is missing and being able to fix it after the fact, rather than having every single healer crash in GVG, or every single person crash in a dungeon such that you have to restart. Many other games do something similar in sort of a “just in case” kind of way. I’m not a developer, I don’t know a whole lot about how this stuff works. But there’s got to be a way to fix this stuff or make it more efficient to fix in the future.


Now we are aware of the above issue and currently working to resolve it as soon as possible. We will keep you updated it.
Please send us your “/TreeOfSavior/system/” directory as it can help us in resolving the issue.


I have the same problem, I logging in, change map, or channel, or warping anything teleport method and the screen stuck, and pick any button or click on the window and I get the window “close program or” wait for the program", at this point I need relog, And the same happens every time I change the map.

1 Like

there is some progress with this topic?

Nothing bad happened to me today specifically, but some of my group partners crashed/dc’d while we were running dungeons. I cannot grant that it was because of this latest patch because if my memory is still ok it happened to me yesterday as well.


It’s a miserable little pile of decisions.

1 Like

And also @teharoil For white screen of death before game opens, go to TreeOfSavior/release and delete user(.xml) and the game should open normal again. I just reinstalled and had it

The issue that I mentioned on this post is still ongoing and the hotfix did nothing to solve it. I’m honestly not surprised, given how unusual it is, but I thought I’d inform of this.
In addition, I can’t stress enough that this began to occur just yesterday, after the patch. So much for returning.
Additional info: My Volume Control, if open the time I execute Tree of Savior, will become unresponsive for a few moments. If it isn’t, and I try to open it while the game is running, it will either take some time to open, or refuse to do so until I’ve closed the client.


Edit Update: Verified game files; still broken. I will reinstall once more to see if anything changes.
Edit Update 2: Reinstalled again, remains broken.

Try this :


Let us know if it worked or not.

I had tried yesterday, and it didn’t work. I’m about to try it right now. I’ll update you on it in a minute or two.

Edit Update: I reinstalled the game once again, and it didn’t work. After that failed, I tried the method you suggested, and the problem persists.

I’ll continue tinkering with it for a day or two, but past that point, I might just drop the game again.