Tree of Savior Forum

[ADDON] LKChat (Alpha)

after the previous maintenence, some of my friends list were being automatically blocked, and i’ve noticed that automatically blocked gold spammers end up on my friends list too

Something weird happened during maintenance, I had some blank names in my list too.
I assume the names were josselsed on your list as both friends and blocked exist in the same array.

However my addon doesn’t mess with friends list entries and only sends a block request when the conditions are met.

I also didn’t think the addon caused it… i uninstalled it and noticed it was getting worst afterwards so i reinstalled it

I swear I think I installed it right but sometimes upon starting up the game I have completely empty chats, I can type and see what I say in guild appear above my head but not in my actual chat box.

@Kotosama @LemonKing
yeh i just updated to the latest and it doesnt let me see the chat, and by that i mean i dont see anything in the chat box and people are chatting around me. The new one basically doesnt allow me to see the chat, and it didnt block the spammers either.

so i went back to the v4b which works perfectly, is there something wrong?

There are some issues with the chat server, its happening with all versions including the default chat box. You’ll have to relog once or twice if chat isn’t showing up properly.
This was happening a few days ago too right before the 24hr downtime.

I really wanted to try your addon, especially with f2p coming, but even though I can see the crown unicode symbol in your post, and on the github site, and can even copy and paste the unicode symbol into steam chat… I can’t copy and paste it to rename a file with it, I can’t paste it into skype, nothing I do gets it to work. I’ve gone through windows updates with language packs, gone through control panel font settings, tried tricks where you close explore.exe via task manager and restart it incase it’s chrome wonking it up, plus so many other things, and none of it works. I have 198 fonts on my system and japanese and korean language packs in addition to the default ones.

I’ve tried a handful of different extracting programs as well, including winrar and 7zip, and none of those work to get the crown in my file names either. It just either comes out as a bunch of random looking characters or an ascii/unicode square. I’ve even tried manually typing the supposed ascii code of alt+1F451 straight into it, and steam chat, and skype chat, and cant get it to go.

I’m currently using the quest addon and the square infront of that addon’s file works just fine. I thought maybe I could test if yours would work with the square but I get a blank chat when I log in. After reading your latest reply to this thread I’m wondering if the blank chat has something to do with that, but I just wanted to throw it out there that the crown doesn’t work for me, on the off chance that I’m not the only one.

Guess I wasn’t meant to use it… for now at least… I’m going to attempt to get the file with a crown in it on my laptop and see if I can throw it on a USB and transfer it at some point, but not tonight :expressionless:

I think that specifically has to do with teams that have since transferred away from the server. So I fully agree; nothing to do with your addon there =)

I’m still loving the addon btw and trust fully that if there is a fix for the overlaps that you’ll find it.

I really don’t even remember what all the constant spam looks like anymore since I’ve been using your addon since you launched it. I honestly forget just how frustrating it was to try and block every spammer lol

Addon works perfectly thanks for the hard work.

Try the older 0.4b if you get the empty chat bug, worked for me and apparently few other people in this thread.

Isnt 0.4b got overlapping chat issue?

i have a problem with the first version of v5 my chat is not align right its in the same line as other people

v5a didnt work for me. Chat show nothing and /lkc not work too.

same with me , also chat whispers are broken

@tekutiger What language sets are you running on Windows? This is a known problem with some unicode fonts on Window’s with other language fonts.

Redownload v5.

This is new, looking into it. Verified: Floating Chat Windows are not showing text, main chat window whispers display fine.

[quote=“Keroro, post:223, topic:208502, full:true”]
v5a didnt work for me. Chat show nothing and /lkc not work too.
[/quote]Try reloading the client a few times, there are issues connecting to the chat server on some server clusters from what I can tell.

New version, v0.5c:
This will resolve any issues with chat not showing up after I implemented preload events.
Also has max font size increased to 40.

I apologize for the bugs, this is an alpha (bugs will happen).

Ayy it works perfectly now. Thanks :ok_hand:

1 Like

I guess it’s just English on my PC, and English + Japanese + Korean on my laptop, lol. Thought I made my PC and lappy identical, but guess not. I don’t even have the option to add additional languages when you I goto CP > Region and Language > Keyboards and Languages Tab.

I think I got it to work, it’s somehow reading without the crown now, lol. Will keep it installed and test it further, but uhm, the bigger issue I had because I was introduced to your added very recently; The lkchat.lua, lkchat.xml, and - I couldn’t find instructions anywhere on where to stick them and they were not within the addon folder in the zip file to assume there, AND they were in their own zip folder apart from the crown file.

Had to ask someone else I knew who had your addon installed already where to place them and if I needed them. I don’t even know how he knew where to place em, or if it’s a common thing to place those files there, or what, but may want to place instructions including you need those and where to put them somewhere. And if they are somewhere already, I apologize, but I could not find them, lol.

(Those 3 files in the addon folder are what made it finally work)

Aside from that, I’ve only just logged into ToS and it blocked 5ish people, I can see chat, but I can’t open the menu via /lkchat or /lkc.

Make sure you have the newest version v0.5c, slash commands only work in ‘Normal’ (/s) chat. The file included in the zip should be extracted in the ToS folder, they’ll automatically be placed in /patch/, not /addon/.

Yup was trying them in normal chat and the addon wouldnt work with the crown file in patch only, only started working after those other 3 files were placed into the addon folder for me. But the crown still isnt showing, its just a square xD