Tree of Savior Forum

Royal Mausoleum Constructor's Chapel Floor 2

Apologies if this isn’t the right forum, I’m kinda taking a shot in the dark. The royal chapel is a bit of an odd place with quest pickups and the like, but without any direct quests relating to it. I notice in particular that there are a few even stranger things about the second floor. Upon entering, you get a status called ‘Voices’ with the description ‘Voices in your head make you thirsty.’ If you kill a few monsters you get a ‘Flask of the King’s Voice,’ which supposedly lets you hear King Zachariel’s voice. Using it gives you the status ‘Voices: Voices of the King’ with the description ‘Secret codes come across your mind’ and it lasts for 60 seconds. When I used it earlier today, I saw a sequence of numbers appear on my screen (8916) but it hasn’t happened again since.

So that’s one weird thing. The other is the Abandoned Altar. When you interact with it normally, nothing happens. If you kill an Earth Apparition, though, you get the ‘Contribution’ status, with the description ‘Contributed to purifying the area. Use the abandoned altar!’ Using the altar then will give you the status ‘Steps of the Soul’ with the description ‘Became as light as the soul through the power of the altar! You can move faster.’ You can then move at maybe 3-4 times your regular speed, but it only lasts for 6 seconds. I notice there’s also a raised part of the room you can’t reach in the Northeast corner. I thought that maybe the speed buff would let you jump the gap in the room to reach it, but you can’t get there in only six seconds.

So that’s what I’ve seen so far of the second floor. Does anyone know anything about it? Or have any theories what all these little things are supposed to do/mean? Or am I just bugged and missed a quest(s) relating to all this?

1 Like

I almost feel as if these types of ‘Dungeons’ would be better served as instances. While yes, it’s nice going to a non-linear place to beat up some enemies, they each have some kind of story that we aren’t being told… At all… Ever…

there is golden goddness in 2nd floor that will give you +1 stat

Maybe you need haste buff in order to reach the Northeast corner…
About the numbers, couldn’t manager to get them…

And there seems to be “things” to do in the 1st and 2nd floor too…

August 9th 2016?
September 8th 2016?
Half-Life 3 confirmed?


Unsure, but maybe we can all agree on the fact that we’re going to need a little more direction in order to do these types of “Dungeon Quests” in this game.

I don’t agree with that. There’s enough hand-holding already.


about numbers - type this numbers in chat near closed door and be happy )

1 Like

While too much hand holding is a bad thing, not explaining mechanics that make an area special is just as bad. The whole “Figuring it out for yourself” only goes so far before it becomes sheer frustration.

In the old days, they were called “secrets”.


What door please? Do tell! :smiley:

I tried to use the potion you mentioned many times, but no number shows up at all.

Can anyone explain what is this all about?

Got stuck at the quest too.

Ones who completed it, can you confirm that there are enough of clues at that single location to figure out what to do, or should we look for additional places?

I actually LOVE hidden quests which give you some tips about how to complete them, but I also HATE quests about randomly finding periodically disappearing tiny spot at the darkest corner of an area with no visual signs of it being special =/

as far as I know, the secret numbers don’t show up if the puzzle has been solved. Most of the time, at least for me, it’s already solved.

I may be wrong about this, I didn’t pay attention for the most part.

I’ve solved it and it stayed open for quite a while/ So yes, most of the time it’s solved.

The real WTF is that jumping…

Ironically enough, there’s nothing on the other side of that jump.

1 Like

WUT?! No hidden treasures large enough to feel like Scrooge McDuck?! Nooooo~~~

I feel that’s the case, but have you got there? At least the 100% completion bonus would be useful for me.

The “Flask of the King’s Voice” is used for the event that occurs at the Prayer Room every 2 hours.
The paths leading to the Chapel Altars will be blocked by smoke. This is where you use the Flask and walk up to the smoke. Numbers appear on screen and once you say them in normal chat, the smoke disappears allowing you to go in and activate the Chapel Altar.

Once all Chapel Altars have been activated the smoke leading to the Chapel disappears and inside will be 6 Yellow Maggot Eggs that you can break for a lot of silver, 10k each.

-Bug: Opening the path to the chapel first will bug the event, causing no eggs to spawn and everyone trying to enter into the chapel getting warped back out.

When you activate the light device at Fatama Oratorium a dozen of apparitions begin spawning continously down the stairs for the 300 seconds it takes for the device to activate. After the duration a buff that regens SP will be present in some areas of the map for a while.

You may also jump down from Fatama Oratorium to the Small Hall, but what most don’t know is you can actually jump back up the wall as well from the corner shown below.

There is also a field boss that has a ton of HP. It will drop some silver and a cube that most likely contains an Earth set item for lvl 40 or a Kanseril Card. Supposedly the respawn timer for this boss is 2 hours according to the database, It seems to spawn in the doorway left from the room where the dozen apparitions spawn during the activation of the light device.

As for the Abandoned Altar, I assume the intended purpose was to jump over the gap to the other side, but as stated it just isn’t enough. However, a psychokino may teleport there. It’ll have tons of mobs packed up. If you aren’t a psychokino, you may have a friend pull you up with telekinesis. You need to be in a duel for that.

Edit: Thanks to greenfoxy21 for confirming, with additional movement speed via buffs it should be enough to jump over the gap.


was already confirmed o.o