Tree of Savior Forum

Problem with "Pond's Purification, Recovery of the Tree (1)" quest?

#1

Has anyone done this quest recently? Quest says to put pots under the three Trees of the Brothers in Apsimesti Crossroads, but I can only interact with under the 2nd and 3rd trees.

Third tree of brothers:


Second tree of brothers:


First tree of brothers:


There’s no “Pot Settling Area” spot to interact with compared to the other two trees.

"Pond's Purification, Recovery of the Tree (1)" quest bug
#2

I did last month with no issues that I can remember…

it must be another trigger positioning problem that seems to be getting more common sadly…

try mouse mode or changing channel

#3

Verifying file integrity, relogging, reentering map, changing channels, and using mouse mode doesn’t work either. A guildie tried doing this quest and he can’t seem to place the first pot either. I’m not sure if this quest is officially bugged or what not… can you try doing this quest on another char and see if it works still?

#4

could try it out later today, maybe can do quest at same time and finish it both :slight_smile:

#5

Hmm, it didn’t work when I partied with two other players, but I guess it doesn’t hurt to try again.

#6

Can confirm, there is no interactable object in first tree, checked with object detector.
The others ones have it, I cant complete too.

#7

@STAFF_Bob I checked the quest too and the quest trigger of that tree is missing…

1 Like
Purification of the Stream, Recovery of the Tree (Quest bug)
#8

I had the same problem trying this quest earlier today, I submitted a ticket, but I got this response:

"Greetings Savior,

Thank you for contacting us!

We highly advise you to engage in a discussion in the forums regarding this inquiry. Players who have already finished the quest will greatly help you.

This will also build a good connection with the other players.

If you have other concern, please do contact us again.

Regards.
Tree of Savior Support"

Do IMC staff not even read these things?

#9

Thats the classic “I don’t know what am doing, check if someone else knows”

of the 3 automated Online game Support answers, you got the best one:smirk:

Same response that everyone else got :smile:

#10

I sent another ticket using ALTERNATIVE LANGUAGE, and within about 45 minutes, it’s suddenly working again.

I was able to do it on both my and my spouse’s account.

I’d advise anyone else to give the quest another shot now, before it breaks again.

1 Like
#11

I checked again today and it still doesn’t work. What server are you on and does the quest still work for you?

#12

Klapedia NA, and I was able to clear it on my and my spouse’s accounts once, but I haven’t gone back to do it on our alts.

#13

Confirmed still not working.

#14

Has anybody been able to complete all the quests after placing down the three sap pots since the last maint? I can’t seem to get the quest after this one.