Tree of Savior Forum

Known Issue: March 19, 2021

Greetings Saviors!

We have made an announcement regarding ‘Known Issue: March 19, 2021’.

You can check the details at our official website from the following link.

Link :

Thank you as always for your continued support, enthusiasm and love for Tree of Savior.


IMC Staff

“Temporary issue on Steam TP Shop”

Resolution time: less than 25 minutes.

“Mouse mode targeting system broken”

Resolution time: 18 months, still not fixed…



What bug? I play in mouse and have no problems, describe it

Most of the time when you hover your mouse over an enemy it doesn’t lock it and there’s no system like keyboard where you press ctrl and it retains the target until it is killed or you deliberately switch to another target. This was the case before and this was changed in a patch in november of 2019. Now to be able to target an enemy you have to explicitely click on it, which is disastrous since most of the time it triggers a “basic attack lock” where your character starts to fire basic attacks at the enemy in a berserk mode which doesn’t get interrupted even by using skills and you have to use keyboard to move with arrows to get rid of that. The problem of not having a specific target is that some skills require an explicit target. If there is none, one of the following may happen: skill goes on CD without doing anything (Hell Breath), skill doesn’t trigger at all (Dambala), or worse, you get a big popup telling you that you must get a target (God Finger Flick).

1 Like

Mouse mode has never worked properly.

Source: I have been playing in mouse mode since release.

They don’t fix the bug cause mouse has never changed in behavior, you have a false memory.
Target lock with mouse has always been disabled. To target lock with mouse you have to HOLD left click after clicking once. You can move with arrows and if you are ranged you will keep attacking even when you cast spells.

Luciferie Kantribe’s bug