"item discarded while equipping gem" After Re Build Patch, I put level 9 red gem on my +16 Velcoffer shield and my gem and shield discarded


#42

they returned the gems that were in the velcof shield +15 trans 10, but the same shield was not returned …
?!


#43

so, after today’s maintenance, i only received my 3 blue gems in market tab retrieve.
but, i still haven’t got my velco staff back. where is it? when?

i already sent ticket “again” regarding this matter.

please help @STAFF_Bob @STAFF_Yuri @STAFF_Amy


#44

IMC ? R U KIDDING ME ?


#45

hello @STAFF_Amy, any update about this? there are still people who didn’t get their weapon back (including me). please don’t abandon us :’(


#46

@STAFF_bob @STAFF_Yuri @STAFF_Amy

Seriously, it’s been over 2 weeks and nothing from my shield ?!
Are you kidding me?
please, an address for judicial intimation


#47

me 5week , HAHA uninstall already


#48

I’m without my weapon for 5 weeks. This is a very sad situation because the staff even answer us :frowning:


#49

still get an automated ticket reply

still no word from staff

helllllooooooooo


#50

they confirm 100% , our item can’t get back
cuz imc care only pay2win player u know ?


#51

@STAFF_Amy @STAFF_Bob @STAFF_Yuri @STAFF_Ines @STAFF_Letitia @STAFF_Ethan

we need a proper answer and solution about this matter


#52


?!?!?!!?


#53

GM

, You gave your word, it’s been over Month !!


#54

More than a month and nothing… How long its take to do this? In others situations, the problem is solved really fast… Its getting even hard support the staff :’(


#55

thanks but no thanks the response to these issues has been absolutely terrible ive already gone and replaced my weapon that i’ve lost. the entire ticket system is pretty worthless so far in every single situation ive had to use it. and this system seriously needs to be improved from this absolutely garbage copy paste system. people had incorrect items returned and a lot of us have waited over a month and never even recieved our items back making the game almost unplayable. this is an extremely poor excuse of game support and customer service. even if my gear is returned at this point its absolutely worthless as ive gone and replaced the item with something better. if i have to rate IMC service so far its a giant F for failure


#56

imc : buy our new tp package to replace ur weapon


#57

I sent 3 tickets asking about the situation. In the last of them, the staff was well educated and informed that they are working as they can. And although I think they’re taking too long, but for anyone taking a gun, they had no foresight when that happened. It is a very sad situation because, faced with the other bugs that disappeared on a larger scale, there was a faster resolution.


#58

More like:

  1. IMC has a terribly designed server-side codebase, that doesn’t back up data to rollback, nor does it allow direct assignment of fields on any user data. Let along channel queue buffer to avoid crash after gem feud, server-side action key buffer to combat sync delay and such. That’s never gonna be fixed.

  2. IMC has no daily check-in on bug report to take action on urgent or easily-fixed stuff. If some staff took a note on this issue early, for example, probably the problem won’t affect so many people. After all, how hard it would be to apply a hot fix that interrupts the discard-item workflow? I am sure Crevox can write an addon for that in minutes. Money hack was handled way too late as well. It would have been much easier if they could just shutdown the server the day it happened. At least it wouldn’t take days to investigate and rollback.

  3. It’s ok not having human resources devoted if they have implemented automatic measures. But IMC has no automatic anomaly detection on marketplace transaction, forum report popularity alert, character key-input pattern entropy, captcha, or anything. TBH, it’s a bad decision not investing early on these measures, because the later you have these, the more your business pays in terms of human resources and player counts.


#59

@STAFF_Amy @STAFF_Bob @STAFF_Yuri @STAFF_Ines @STAFF_Letitia @STAFF_Ethan THERE IS still no resolution to these problems


#60

I got my weapon and shards back!
Try tickets, guys.


#61

Good to see your issue resolved :+1: although you did wait some time for it