Tree of Savior Forum

Game wont start after launcher

#1

hey guys, my thread from steam here too, maybe i can find here help

hey guys,

my problem, game wont start, the “launcher” screen comes, jumpes from 0 to 100 and then nothing happen. game wont start.

i tried to the xml removing stuff, nothing changed,
i installed DX10, done the copy paste stuff too, with install also wont work.
i tryed to veryfie game files, aleays keeps saying 4 are missing (when delete the xml ofcourse number goes up for number of files i delete)(after launcher start the 4 files go missing again)
i tried the exe in the release folder too … still same problem …
i tried to run from 2 different drives, even on ssd and hdd, still problem
i redownloaded the game and reinstalled allready, same problem (yes i deleted the files in common folder before)

after every fresh download the launcher takes a while, seems he is patching, after that hits the problem. at first start i get the warning that a dxfile is missing, okay no problem done the copy paste and installed on my own the dx10. after second redownload of the game, i did copy paste the 2 missing dll files directly even before launching first time the game, dx10 setup went normaly and launcher started patching, but then game wont start …

hope for any help.

1 Like
#2

Hello @BlackyGER

Thank you for bringing this matter to our attention. Kindly send a ticket to our Customer Support Team to further assist you with this matter.

Regards,
GM Francis

#3

allraight, thanks, wrote the support ticket, i hope it wont take much time to solve since im new to this game ^^ and i want to play

#5

re-open steam… and close client_tos.exe in task manager…

#6

hmh, im not having smth like this named in task manager … updater mc jap/ko language and thats it
i also tried some tips the support gave me, like switching to Microsoft Visual Studio 2015 (yes i had to downgrade vom 2017) but nothing helped so far … its annoying … i found the game yesterday on steam and now this happen -.- i just simply want to play

but anyways, i think its not a issue on my rig side since it happend on a second rig i used for testing too. exactly the same problem. the rig has exactly the same system specs as my one, just a different software on him (i use win10pro and the other one win10 home), thats the only difference. both rigs are asrock z77pro4 boards, i5-3570k, 16gb ddr3 corsair vengeance, gigabyte 1060 xtreme gaming … both got ssd´s and hdds.

both use 64bit os, win and drivers are totaly up2date (i double checked it) i tried all what was arround on the net and nothing helped.

maybe i record later a little video what happens since im a streamer … would be helpfull i guess.

1 Like
#7

try to change the compatibility of .exe

tos.exe and client_tos exe to win 10 following this guide

#8

still not working, but considering to the fact on steam forums that more and more ppl, wich just downloaded the game for the first time like me, show up right now and speak up there with exactly the same problem as i do, feels like its an game issue.

special the part that ALWAYS 4 files are missing after the launcher closed (i noticed by steam file verification)

3 Likes
#9

Hello @BlackyGER

Our Customer Support Team recently responded back to your most recent ticket. Kindly refer to it for this matter.

Thank you!

#10

hey @GM_Francis

yeah im aware of that but it seems they just still thinking that the issue is on my side and i have no clue what i am doing.

i told em now multiple times i redownloaded the game, downloaded patch again, made clean installations of the game even with regedit cleaning before, folder cleaning and so on … ive done this over 20 times now on 2 different rigs and always the same issue. i also told him now multiple times my steam is fully up2date … because its automaticly updates itself, you cant play with an outdated client.

looking through steam forum other ppl also have exactly the same issue as i do …
well … i wanted to stream this game with my wife since we are streamers, but after all this im no sure anymore if we will …

1 Like
#11

Well i got the same issue as Blacky, nothing of the solution wich i found in the internet or steam helped me out…
always when i start the game the window pops up with the Tree of Savior title, in the corner there is the loading count , it directly switch from 0% to 100% and then its closed without starting anything new…

1 Like
#12

think it’s a game issue too.

#13

I dropped maybe 500 euros in this game, and it’s the worst customer care I saw in my entire life, not only for what happened to you.
I’ll make a video when the game will work again then quit.

#14

replay from support

my reaction: :man_facepalming:
my wife reaction: :woman_facepalming:

like

i mean seriously … im an streamer, they know this … but they treat me like i know nothing -.-
atlast one good point, they try to help me, even if those answers are no help at all since they are basic stuff a geek like me is doing anyways … also a good point, i dont have to wait long for replays, so they are fast ^^

1 Like
#15

hey have u hope they will solve this problem? those 4 files is always missing here too. and the strange is that after the launcher closes, nothing happens, there is nothing in task manager. i already tried to reinstall, run steam as admin, etc.

i met tree of savior this month, probably the bug is happening over recently installations.

anyway, what’s your stream channel? i’m interested.
greetings from brazil. sry if i cant speak very well.

#16

4 files?? what’s files??

#17

thats what no1 knows ^^ everytime the issue happens, if you check gamefiles, 4 files are missing, they get redownloaded, but after start again 4 files got missing. but if u had read my first post, its allready in there ^^ i named this issue ^^

#18

let me see u game base files in a screenshot

#19

this one? or files of wich folder you want to see?

#20

TreeOfSavior files folder

#21

here we go