Tree of Savior Forum

Game not starting - can't access "system" folder

Date and Time(Please, specify the timezone) :
12.06.2020
Issue has been persisting over the past few weeks.

Server Name:
None, as the issue occurs before server selection.

Team Name:
Eillis. (Doesn’t matter anyway as the issue occurs before game start).

Character Name:
None. Issue occurs before game start.

Bug Description :

I am not able to start the game at all. When I try to start the game, game process shows up for a brief moment and shuts down right away.
I noticed that I have a few “Info” folders with files in “TreeOfSavior/system” folder, to which I have no access rights. I am not able to delete these folders. Inside these folders there are a few other folders which I can’t even open (all on screenshots).

It seems that these folders with permission restrictions are preventing me from starting the game.
Changing folder/file permissions does nothing. I have “full control” permissions set for these folders.
The only way I have, to temporarily fix the problem is using a special program (Unlocker) to delete these folders at system start.
After I delete these folders in this way I am able to start the game.
This solutions sometimes works only once. After I close the game, the problem comes back right away. Sometimes the problem goes away for a few days or a week. Eventually it always comes back though.
I have no similar problems with permissions with any other software I use on my computer, not even the ones that require administrator privilidges to run.

Steps to reproduce the issue :

  1. Double-clicking game icon to start game. Nothing happens.

Screenshots / Video :
permissions_1
permissions_2
Screenshots are in Polish, but I am sure that you can recognize the popups.
One says that I need right permissions to modify the folder.
The other says that folder is inaccessible and access is denied.

System

  • OS : Windows 10 Pro
  • Country, Region : Poland

Hello @darkexiler,

Please send us a support ticket with the details of your concern. Thank you!

1 Like

I submitted a ticket.
Thank you for quick reply!

I have this exact same problem. have you fixed this yet? if so can you post it here? thank you very much