Tree of Savior Forum

Game Crashing When In Windowed Mode


#1

Hello! I just started playing the game works fine in the default full-screen mode. However, I’d like to play it in windowed mode for several reasons.

I’ve tried switching over to windowed mode from within the game options/settings as well as by changing the user.xml file (“mode=1” to “mode=2”, which I suspect is what happens when you change it in options anyway).

However, both these methods yields the same result which is that ToS will launch but get stuck on a white screen immediately and then crash right after. Is there any way I can fix this so I can play in windowed mode?

PS: Sorry if this question was asked before! I’ve been looking around but I just couldn’t find it.


#2

Yeah, i have been dealing with this problem too, since a few hours ago. No idea how to solve it.


#3

Always verify local cache on steam to make sure no file was corrupted by the changes you make…

Also, knowing what OS and system you are using helps identify the problem too…


#4

I have same problem, as far I can tell, you can switch to windowed mode after launching the game, but cant lauch in windowed mode (will crash). I dont know why…


#5

Everything is up to date and verified. Also, I’m on a Windows 10 laptop with the following configuration;

Processor: Intel i7-8750H.
Dedicated graphics card: GTX 1060 6GB.
Memory: 2666Mhz 16GB DDRAM
Storage: The game is installed on a HDD.

Edit: The game runs very well on full-screen mode, with the FPS only dropping when doing challenge mode with a full party (to a minimum of 20-30 FPS).

Also, I can’t even change into windowed mode after the game successfully launches. It doesn’t just crash on launch but as soon as I switch modes.


#6

could be the HDD…

have you tried with the game installed in the laptop?_?

if it still crash you can just uninstall it after testing


#7

I can’t install it on my SSD but that seems like a major flaw if the game crashes cus it’s on my HDD :frowning:


#8

is just a possibility…

also, do you have V-sync on or off?_?

mine is off…


#9

Er, it was on, but I tried it after turning it off and it was the same.


#10

Since when are the files on the HDD?_? it could be that some files might not be updating properly…

I would recommend a re-download, but don’t unless your internet is really fast…

that been said, have you tried if alt + enter works on resizing the game?_?

I might go in, try it and edit if it work or not…

EDIT: ALT+Enter doesn’t work in this game (at least not for me)…


#11

It’s been on there for a couple of days since I installed it. If it comes down to reinstalling, I’d rather just swallow it and play in full screen haha.


#12

Omg I have this problem too! I just returned to TOS and now have this problem, I cannot play :frowning:

Any fixes?


#13

Locate the “Steam” folder in your program files. Follow this path, Steam>SteamApps>Common>TreeOfSavior>Release and open the “user xml” in notepad

change Resolution mode=“2”(window mode (cann’t launch the game)) to Resolution mode=“1”(full screan)


#14

I want to launch it in windowed mode though. :frowning:


#15

there is a possibility that this might be connected and just be the results one big problem instead of 2…

Can I see an image of all the files on C:\Program Files (x86)\Steam\steamapps\common\TreeOfSavior\data

or compare it to mine


#16

@Ketsu @iorawerks wanted to know if the problem still persist?_?

I was playing around with windowed mode res and notice that game cant load windowed if resolution is the same as computer…

what I did was go to the [user] file and drop the length and height of it by 10… or 20 and that should fix the problem…

make sure it doesn’t match or surpass your display # on the game files…