Tree of Savior Forum

Client no longer fitting screen

Date and Time(Please, specify the timezone) : July 23th, 2017

Server Name: Klaipeda (and maybe others)

Team Name: WarNux (and other people)

Character Name: All

Bug Description :
Was patching the game normally until the client launched and the screen was minimized as default. No matter if I maximize or change resolution, the client won’t fit the screen. In this screenshot, it looks like a normal minimized screen, but it cannot be resized nor fitted to screen.

Steps to reproduce the issue :

  1. Patched game normally
  2. Started with a small screen
  3. Tried to maximize and change Resolution
  4. Tried to fit manually and didn’t work

Screenshots / Video :

Game Control Mode (Keyboard/Joypad/Mouse) : Keyboard and Controller


i have a problem also try to fix many way

I also have the same problem. Can the GM please handle ASAP? Cant play like this…

can we please keep it this way? for some reason, the game runs way smoother now, I’m afraid that by changing the resolution, we go back to that laggy crap again

  1. I think a lot of players including myself prefer playing fullscreen as opposed to a small window on top left corner with white borders. Not to mention itty-bitty text etc.

  2. I dont think that lag you mentioned has anything to do with screen resolution. And even if it did, there should be a solution that doesnt sacrifice a portion of players.

1 Like
  1. the window isn’t small, that must be a bug.

The new resolution of the client seems to be forced 1024x768 when you start the game; it should appear as a large window on your screen (unless you use full HD [1920x1080] which you shouldn’t, but even then it still covers a huge chunk of your screen).

the fix applied during today’s maintenance is that we changed it so that the game restricts the resolution modes to only those supported by direct X. For the white border issue, try changing the screen resolution from the options UI instead of clicking the square button on the top-right corner to maximize the window and it should be fine.

so is that the reason why the game runs so well now?

was it a direct x-related problem that made the performance worse?

I am not sure about what’s been causing the performance issues exactly but the restriction in resolution mode came about as a solution to client crashes and user.xml issues people have been having from my knowledge.

So, its intentionally implemented? What is “direct X”?

1 Like

Managed to fix the issue from my end. Went to display settings in desktop and set the "size of text, apps and other items from 125% to 100%.

No more issues. Hopefully this can help others who have similar issues.


It helped thanks you , Brother.

Another solution given by other people:


1 Like

I think you’ve misunderstood the thread. Fullscreen isn’t forced. All you have to do is change your resolution in the options menu.

Also just letting you know that we will be applying a quick patch tomorrow to allow the users to use the top-right corner button to maximize their game windows :smile:

1 Like

I cant even access the options in-game.

This is as far as I can get

try using this user.xml file user.xml (1.2 KB)

I already have that…

Just to let you guys know, we can change the window option by adjusting it at the User doc inside the game paste. This might help you, @hubertorito