Tree of Savior Forum

Can't Talk to Npc/Swich Char/Swich channel


#1

Please fill in as much as you can :

Date and Time(Please, specify the timezone) :

Server Name: Klaipeda

Team Name: Nihgtbringer_

Character Name: i tried with 2 chars currently “Nightfall” “Abaddon”

Bug Description :
I just log in get 10 cubes +1 see than do get anything try to relog can’t close the game log in with other char and can talk with npc/ wich char/ swich channel also i tried with the one who opens the cubes and still cant do anything :confused:


#2

got the exact same bug. How can we change class if this bug still exists… :confused:


#3

1 more unlucky bastard here! I’m trying to fix using “Verify Integridy…yadayadayada” and waiting for the result yet.
Edit: did not work.
Edit2 (SOLUTION): use any scroll to move to another city. It solved it.


#4

Try disabling all addons first. Because there were many issues with addons with kTOS Re:Build update as well.


#5

I tried uninstall all add on and didn’t work curreantly i delete lastes patch and dowloading again hope it work


#6

I got the same issue too, i cant even switch channel or anything, have to end task ToS. After login again everything is fine. Look like have a problem with connection to sever in the 1st try.


#7

Open the folder /Steam/steamapps/common/TreeOfSavior
Open folder addons and delete all folders inside of it
Open folder data and remove all itens that start with " _ "(it’s the name of the addon, ex.: “_betterquest…”)

Optional: you can just copy those folder/files outside game folders, so you will not loose your addon list for future re-install.


#8

I got the same issue. I tried to uninstall all addons and I tried to verify integrity. :’)


#9

My friend solved that problem uninstalling all the add-ons.

Seems like there is a problematic add-on.


#10

My only addon was the “Show Hidden Buff” and I deleted the .ipf file (and the empty folder in addons), but it didn’t work. :’(


#11

Don’t you have the Card Experience viewer or similar?

For now, I know about 2 guys with that problem solved by removing the add-ons.

Is it possible to try doing a clean reinstall? Maybe there is an add-on that you cann’t see that is causing problems.

Sorry I can not help more than that.


#12

You can simply move out of the map/city what you are and it will work for a while.

This look to be a connection issue, you can see it by minimap, when you move away your minimap stand still in the position what you have logged


#13

Try deleting the addon data in appdata\roaming too


#14

I tried 2 times (one this morning and another after I re-installed the addon manager to see If I have another addon… I don’t). I tried delete the .ipf files from yesterday, then download them again… It still happening. :frowning:


#15

This is not caused by addons, it is a server lag and a fps failure, it changes the map and it comes back, this should solve it.


#16

My problem is solved by verifying the intergrity game files.


#17

Sadly for me, I have no add on. Passed the verified integrity of game file in steam but still encounter the same issue. Worst is while this bug is around I have to be stuck in instance for 1 minute after it is done as there is no way I can change character or press the exit dungeon button as the reward page didn’t even appear.


#18

Hi, guys.
I am not having this issue, but a friend of mine is having this one consistently.
I will list what my friend does and hope it, at least, let you play for the day.

The way he goes to “fix” it (not actually a fix, cause it happens other times):

  1. Log in
  2. Get stuck without being able to interact with anything (usually in Klaipeda, so let’s take that for the example)
  3. Walk out of the map he is in. (Klaipeda to Gytis Settlement Area, for example).
  4. Walk back to Klaipeda and be able to play normally.

#19

yeah, same here. Please how to fix it :frowning:


#20

I have a same problem… Try tickets, but not resolutions…We need play, but how? Impossible… Cant talk with all NPCs… Market, teleport, masterclass… Is sad…