Tree of Savior Forum

Can we FIX the "I Can't Talk to NPC bug" already?

#1

Date and Time: 3 weeks ago till when ever it is fixed

Server Name: ALL OF IT

Team Name: on behalf of EVERYONE

Character Name: EVERYONE’S CHARACTER

Bug Description :
You can’t talk to NPC, Can’t interact with dungeons, Cant use the Warp statues, unless you warp to the next map and come back in. It was a mild inconvenience on the 1st week but leaving it unfix for more than 3 weeks just because it has a quick fix where one must go to the next map to fix it is just… and now its infuriating. Specially if you need to interact with npc inside a dungeon/raid (FFL raid) or if you just came from CM and is overweight, you run to the Storage NPC and cant talk to it, now you need to painstakingly run slowly to the nearest exit warp that’s a hundred miles away.

Please FIX IT. or at least tell us that you are working on a fix or something.

Steps to reproduce the issue :

  1. Log in to game.
  2. Log in a character
  3. Talk to NPC
  4. YOU CANT.
13 Likes
#2

I have this problem, too. It persists in TBL which means I can’t see my buffs or debuffs and it’s annoying.

#3

Druid bugs took over 6 months to fix before IMC decided “■■■■ it, let’s just delete Carnivory and Sterea Trofh”

So maybe in another 5 months IMC will just delete NPCs.

4 Likes
#4

Quick Workaround : Change your client language in game setting and change back.

It’s a bug occurred due to de-syncs when loading.

Spaghetti code regardless :tired:

Also, symptoms of this bug is spot-able without talking to NPCs when u have fps counter turned on and it shows “0000” instead.

3 Likes
#5

It is definitely a desynchronization but changing the language does not help me at all, I have been dealing with this problem since the big update, imc is unable to give a solution to this problem.

#6

bump need more attention to this /20characters

2 Likes
#7

I have the same problem, and it persists even after i change maps and come back. My characters are stuck and I can’t play at all.

#8

I’ve just watched a video with a strange issue. Doesn’t seem to be a desynch problem, so it could be a similar problem.

Around 42:10, the guy enters Klaipeda, moves around, you can see other people moving so it’s not a desynch problem, but the guy cannot interact with anything. If you look at the minimap, the position of the cursor doesn’t move at all, just like the character was “stuck” at the entrance.

When you have the “can’t talk to NPC” problem, do you also get the cursor stuck on the minimap? If so, this seems like the position of the character that would be corrupted, so you can still move around on the client which is mostly independent, but all attempts to connect to the server would fail because it couldn’t match the location properly.

1 Like
#9

I have the same problem, I have seen that when this error happens when it is loading and blinking before finishing loading all the npcs and players, it happens on any map and it is more frequent when there are a certain amount of players a bit high, those of imc They told me it was a problem of lag and they gave me some instructions that did not solve anything, like checking the integrity of the files and I always see 4 files that are not validated and are downloaded again and nothing is fixed, everything started from the rebuild and it happened only in dungueons, but since they put Irredian Shelter started to happen in all the maps.

The way I deal with all this is to buy many scrolls to orsha and klapedia and pray that the **** does not blink.:tired_face:

#10

I always log onto a character standing next to a map-portal to change map and then log on whatever character I actually wanted to play xD…

Yeah, this has been an issue for way over a month now I think?

#11

Hope this bug is one of those important tasks the staff are looking into.

3 Likes
#12

This helped me a lot today … my problem is I can’t click on the storage NPC and i saw the " change language " from above comment and it worked! thanks skywing22 XDD

1 Like
#13

This addon solves the problem. It’s basically the language change thing but you just need to press a button.

2 Likes
#14

Have the same problem. It happends 9 of 10 times i log into on one spesific char. Cant talk to npc, change channel and cant close game.

Changing the language worked. Thanks.

#15

how can i get this addon?

#16

https://mega.nz/#!4wMjlIQI!cqU6nUz3Y7f1rxhNJHs0fwG8lRgEzeJXCcfnmZyZSkk

2 Likes
#17

Looks like they finally fixed it!
:tada::satisfaction::tada:
Thank You TOS dev for fixing this issue.

#18

This is clearly not fixed, I had the problem yesterday with one character (with arrow not moving on the minimap). And it’s worse now… Almost every character that leaves an instance gets thrown out of the map. Do Saalus -> wait for instance to close -> get pushed back to entrance -> get sucked by map change -> end up in Pilgrim Path.

#19

I’ll look into it… for now I’m not experiencing this bug since the update might just be lucky.
I usually experience the getting pushed back to entrance bug when exiting velco raid so far I have not experience this in saalus or DG.

1 Like
#20

There was a server issue about 6 hours ago that caused a temporary problem with staying connected to the game; this was resolved.

Please post if you get the “UI/NPC bug” again going forward.

1 Like