Tree of Savior Forum

Broken dll file : TosSteamClient.dll

Hello Savior!
The Ingame Notice just minutes ago were sent by our mistake. Thank you for letting us know.
We will soon send a notice clarifying the issue.

Have fun with Tree of Savior!


Here’s some of the “NoData” images I see.

Annotation 2020-04-21 205353 Annotation 2020-04-21 205504 Annotation 2020-04-21 205541

Reverify your client. This issue is usually related to the language/English folder where it was possibly corrupted during the download process.

Or you can take this entire folder from someone with a working client


Thank you for images, saviors!

I’d like to ask you for investigation.
Have you ever purchased DLC “Founder’s pack” before?

I have Second Anniversery Present and Founder’s Server: Exclusive Access 2 attached to my Steam version.

@Ersakoz I already reinstalled it 4 times. As well as deleted the ToS folder from the SteamApp/Common location.

Have this same problem, also have founder’s pack dlc

Thank you for reply!

Please try to uncheck the DLC “Founder’s pack” then verify the integrity.

Alright it works again. This should probably be on the steam forums stickied or something.

I have founders, so should we uncheck it then verify integrity? I’ll try it, then get back to you if its okay.

Yes, that’s right. First of all, uncheck the “Founder’s Pack” then verify the integrity.

Thank you for try.
If the matter is persisted, please send us a ticket with details. :smiley:
I hope it works!


ah it works, but my some of my working addons before this stopped working

UPDATE : I’ve uncheck the “Founder’s Pack” and the game starts running normal for me now. There is no pop up textbox of “TosSteamClient.dll”. Thanks @Staff_Alex , really helpful! :slight_smile:

Like what addons? I’m curious to know. :slight_smile:

I am really happy that your matter is solved. Thank you for letting us know about the problem.
I hope you enjoy your adventure in ToS! :smiley:



thank you @Staff_Jin it works :slight_smile:

I find it really funny how after coming back to this game since 2018 and somehow the staff on the fourms are much better at settling game issues than the actual website’s support ticket staff. I literally get the same copy and paste issue since 2015.

So I guess from now on if I have any issues I should just ask on forums rather than sending in a ticket then.

1 Like

Posting to say this solution worked for me as well. Thank you!

woo wanted t let you know I had this problem and it fixed it for me as well.

I have the same problem, I’ve already verified the game integrity multiple times and still get that $nodata. And my latest ticket seems to be ignored.

Greetings savior!
Here’s the solution. I hope it can help you :slight_smile: