Tree of Savior Forum

Broken dll file : TosSteamClient.dll

Please fill in as much as you can :

Date and Time(Please, specify the timezone) :
11:07 pm
Server Name:
SEA (Telsai)
Team Name:
Killier
Character Name: KillaJ

Help!!! I’ve already reinstall the game and it’s still the same :frowning:

Steps to reproduce the issue :
1)
2)
3)
4)

Screenshots / Video :
(attach screenshots or videos regarding the bug)
image

Game Control Mode (Keyboard/Joypad/Mouse) :

System

  • CPU :
  • RAM :
  • Graphics Card :
  • Mainboard :
  • Storage :
  • OS :
  • Internet Connection :
  • Country, Region :
1 Like

I am experiencing this as well as $nodata$ issues; I’m wondering if they are connected.

Same as Hilsun.
broken dll + $NoData$.

Same Problem Here. NO data and TosSteamDll corruted

+1 same problem+$no data$

So, a little update for those having $NoData.
I just create a second steam account and download the game again.
Everything work (no broken dll, no $NoData).
I tried to log into my main steam account, launch ToS.

The launcher download files… TosSteamClient.dll and the ‘English’ folder.
Launched the game… $NoData and broken dll are back.

But… i saved the the working ToS :stuck_out_tongue:
Copied it in steamapps. Launched the game. Launcher do no download. But (again :/) TosSteamClient.dll error. A new one this time. Seems like the dll is link to steam account.

So now is the “good” news.
I check the integrity of the game, launched the game. Launcher dl things and closed himself. I copied the “English” folder (TreeOfSavior\release\languageData\ ) and laucnhed the game.
I still have the broken dll, but the game work (no $nodata$).

Trying to return to the game after so many years and I have the same problem as everyone. (Klaipedia)

I wonder what the difference in the English file is. Any way you can make the functional file downloadable? I’d love to be able to see my button and menu options again. :smiley:

Same problem here. UP

Hello savior!

I’d like to ask you a question for more details of the issue.
Have you ever purchased DLC “Founder’s pack” before?

I will be waiting for your answer!

Thank you.

Hi @Staff_Jin,
while you are still active in this thread.

Just minutes ago,

SEA:

NA:
image

Is this announcement pertaining to the fix for this .dll issue + ichor equip/unequip bug, or just a typical notification error

Hello Savior!
The Ingame Notice just minutes ago were sent by our mistake. Thank you for letting us know.
We will soon send a notice clarifying the issue.

Have fun with Tree of Savior!

2 Likes

Here’s some of the “NoData” images I see.

Annotation 2020-04-21 205353 Annotation 2020-04-21 205504 Annotation 2020-04-21 205541

Reverify your client. This issue is usually related to the language/English folder where it was possibly corrupted during the download process.

Or you can take this entire folder from someone with a working client


image

Thank you for images, saviors!

I’d like to ask you for investigation.
Have you ever purchased DLC “Founder’s pack” before?

I have Second Anniversery Present and Founder’s Server: Exclusive Access 2 attached to my Steam version.

@Ersakoz I already reinstalled it 4 times. As well as deleted the ToS folder from the SteamApp/Common location.

Have this same problem, also have founder’s pack dlc

Thank you for reply!

Please try to uncheck the DLC “Founder’s pack” then verify the integrity.

Alright it works again. This should probably be on the steam forums stickied or something.


I have founders, so should we uncheck it then verify integrity? I’ll try it, then get back to you if its okay.