Tree of Savior Forum

Anyone stuck on the final Episode?

I’m doing the final episode

“Miritinas Storage”
Area: Laima’s Sanctuary
Objective: Speak with Goddess Lada.

Episode Lv. 456 and my char is at 458. When I go to the NPC the mini map shows the yellow quest ring around Lada NPC but she’s not clickable. I’ve tried 32, 64 bit and both mouse and keyboard mode. I’ve sent in several tickets but they’re still trying to find out what’s wrong. Has anyone encountered same issue and figure out how to continue with the episode?

have you tried using the space bar to trigger the conversation?

If that doesn’t work, I think it could be a general error, since I cannot seem to be able to talk to her,either, although the char turns around to face her when you are close to her and use the space bar/controller button to initiate the conversation as with every normal NPC.

It could be that one of the few recent patches actually removed her NPC reaction script altogether, meaning she’s no longer an object that reacts on action, but just a moving object right now.

I’ve tried everything including keyboard mode + space bar. Nothing seems to work. And sometimes there are two Lada NPC’s stacked on top of another (I could tell cuz the wings flapping at different times). Last ticket I submitted they said they put it into special department to look into it. Hopefully it gets fixed after today’s maintenance.

And of course it’s not fixed after maint…

1 Like

So it’s not server wide issue because I could get another character past that stage. And I still have yet to hear from the devs/moderators. And it’s been like this for awhile now. What kind of rpg game is this where you can’t continue with main quest and they can’t fix it for over a week. I even sent a video recording of it because they asked for it and they can’t do anything for this long. YIKES

Did you get it to work?

I didn’t try it again so far, would need to level another character to 450+ but I’ve got no time to do that right now.
Maybe it’s going back to normal after the maintenance…

I was wondering about the one that doesn’t work. My main still can’t get past it while another one could.

Is this for real? It’s still not fixed and it’s been over one month.

hope u can get closure :slight_smile: