Tree of Savior Forum

Weapon Auto swap lagg (again) 2018 Edition

Date and Time(Please, specify the timezone) : Since R10 patch came

Server Name: Fedimian

Team Name: Gernst

Character Name: Bowman

Bug Description : Are there anyone else who has this same annoying lag everytime using autoswap feature during skills? My build is ranger3falco3hacka2 and i use 2handbow as mainhand, and autoswap to xbow+sword. Everytime i use hacka skills my fps drops for a second, the game freezes for 0,5 or 1 sec and than goes back to normal. Sometimes this gets awful, when dealing with several monsters in a party, or doing CM runs, the lagg is disappointing. I really like this build, but this totaly makes me want to switch. When changing to crossbow and sword it is okay, no problem.
The worst is with Cavalry Charge. Usually i dont even see the charging animation only the last frame, it is not a charging skill its more like a teleport. Cutters animation is ridiculous, if i want to fire the skill in quick succession, no animation played. Its so bad to look at it, no fluid gameplay, makes me think my computer is dieing. :sob:

Here is a video of me showing how the auto swap feature is working on Fedimian:

And here is another video from an iTOS server (i dont know which one, sorry) where there is no lagg:

Still i’m not quiet sure it is a server side problem or client side, but i’m guessing its the latter. What i tried:

  • Uninstalling the game and installing a clean one
  • Deleting all addons, as i thought those addons that are connected to equipments, inventory might make the function to work on a larger time period, but than i was wrong cause it remained the same.
  • Placing the autoswap weapons on a hotkey, so i can do a quick swaps manually, might help a bit, but no
  • Reducing the inventory space, ergo throwing out everything that i dont need and minimalize weight of the character. I have red somewhere on TOS forum it can be connected to inventory space, but its just plain stupid, what garbage coding would that be…

What i did not tried (yet):

  • Reinstalling the game onto an SSD. Currently my system stays on a 120GB SSD and everything else on a HDD (7200rpm 16MB cache). I’m only hoping this one.

If anybody has some feedback on the matter, please share with me. I can play like this, but if it can be better than i would change, i am already thinking about going back to mergen2. Already have 2 mounted class. If only IMC would come out a mounted 2handedbow archer in the future that would be great.

Game Control Mode (Keyboard/Joypad/Mouse) : Keyboard


  • CPU : i5-4460
  • RAM : 8 GB DDR3
  • Graphics Card : Nvidia GTX 750Ti
  • Mainboard : -
  • Storage : 120GB SSD 1TB HDD
  • OS : Win 7 Ultimate 64bit
  • Internet Connection : 600MB Fiber
  • Country, Region : Europe, Hungary

Hello Heavenpiercer,

Thank you for bringing up your concern to us. We will definitely have the proper department check these issues and have them review it to see what we can do to fix this. For the mean time we ask for your patience while we have these issues resolve.

  • Set everything to low, disabled vsync, enabled gaming mode on my graphic card (ToS has high affinity on my OS), now i have 120~180 FPS on empty maps and around 80 in cities, but the sudden stutter, lag still there. :slightly_frowning_face:

r10 patch removed prior r9 optimizations. I browsed previous patch notes and found these, could be leads to fix this once and for all:

Stability Measures

  • Revised and removed logic responsible for triggering client crashes in order to increase overall stability and compatibility.
  • Removed elements generating memory leaks in order to improve client optimization.

Client Performance Optimization Patch

  • As announced earlier last week, during the maintenance of April 10 we will be applying a client performance optimization patch that’s expected to reduce lag issues and improve frame update processing times.


Between April 10 and September 4, the game was playing nicely: no lag, little stutter. After September 4, it was the same as if the optimization patch was never applied.

P.S. : I’m sure other patches have been reverted by the r10 release. For example: Scheduled Maintenance for May 29, 2018 – “Jumping on the roof behind the Market Manager in Klaipeda will now be easier”. This is clearly not the case anymore, as it often takes me many times to make the jump.

1 Like

I knew the cause of this problem is on my side. I found out that my Addon Manager cache is not flushed properly, so i deleted all addons once again, together with tree of savior addon manager in the appdata, and its fine now. Its not perfect, but LOT BETTER then before. Bye bye teleporting with Cavalry Charge :slightly_smiling_face:
I started to try out the game with addons, one by one. Installed Better Quest, Zoomy, Colored Item Names, Status Check, no problem till i got Hair Acce Enchant addon, the one that makes your enchanted headgear have colored stats. Once i installed that i run the game the lagg and stutter came back. Ofcourse i deleted it and rerun ToS again, and it was fine.
So right now its pretty good, i use a lot less addons now, but many players can play the game without them anyway so why cant i. After the hair acce addon i did not want to experiment further so left it as it was.

The remaining stuttering and lagg is probably caused by the reverted optimization patches, low GPU, HDD speed, connection issues, but it is not usual, as it only happens occasionaly, so no big deal.