Tree of Savior Forum

Time to let the anger out (channel matching bug)

Ok after a miserable day trying to do instanced content, I finally reached the point of no return and I’ll have to let the steam out. The following is going to be really nasty, so hide the kids and turn down the speakers… Ready? Here we go…

So currently there is the Summer Festa event, which encourages players to do instanced content, even if they don’t need it. Three daily runs of level 50 dungeon on every char, Saalus on every level 240+ char, raids… Plus the Uphill Defense missions you have to do 4 times a week and Boruta Guild mission. You get the picture… it’s boring, it takes long… and it’s damn stressful. And now you have this STUPID bug that prevents you most of the time from being matched with your party mates in that damn instanced content. Let’s look at a Sunday in HELL…

Step 1: dungeon 330 instance

So yeah, there’s always a guildie trying to do that dungeon and since I got a char that’s still not 410 I decide to do some 330 runs instead of the faster dun 50 solo. But guess what… the STUPID ENGINE IS NOT F*CKING ABLE TO ADD 1+1 to match the only two idiots on a whole server queuing for that dungeon! And this for FRIGGING TWENTY MINUTES! And after all this, you still need two EXTRA minutes to start the instance after we both clicked on match 2 to 4 option… but of course after wasting twenty minutes we can waste two more, no problem. Dungeon runs done, people shouting for Saalus, let’s go…

Step 2: Saalus runs

Been waiting for a couple hours to see a party rolling, so let’s finish this chore quickly. Wait, why am I alone in Castle Mission? Press F6, everyone is in channel 11, I’m in channel 8. Great… Bail out, try again… now I’m in channel 22. Bail out, switch channel, rejoin, now it’s channel 6. Bail out, switch charaters, enter, channel 23. REPEAT THIS BULLSH** TEN F*CKING TIMES BEFORE BEING ABLE TO ENTER THE RIGHT CHANNEL JUST TO FIND OUT THE RUN IS OVER :face_with_symbols_over_mouth::skull_and_crossbones: Next run goes well, next one it’s someone else that is unable to enter, and this goes on for some time until people leave and I’m still supposed to do two more runs. So what to do… waste time soloing the damn thing or waste time waiting for more people. Bah there are usually more parties later, I wait… especially since someone shouted for Uphill. I thought I’ve seen the worst, but it’s nothing compared to what is about to come…

Step 3: Uphill Defense

I’ll pass the twenty+ minutes we’ll have to wait for a 5-char party to get formed and everyone being ready. I’m lucky, it’s the first Uphill shout I’ve seen in days and I really want to craft those new legend accessories. Let’s do hard mode to maximize those points! First run goes well… but at stage 15 I get “mission failed” message, the other line struggled to defend the torch and couldn’t cope with the last wave. Oh well, it happens, let’s do normal mode instead. Round 2, we enter, mission start, I choose normal, mobs start spawning… but wait where is everybody else? Guess what… THEY ARE IN ANOTHER CHANNEL! Since I don’t think we lose the entry by simply leaving, we all bail out and restart. I enter again, and immediately get killed by the 100+ mobs in the center of the old channel that was not reset, while the other guys were put in a brand new channel. WHAT… THE… F*CKING… HELL??? So that’s a second entry wasted for me, great… At this point, SCREW THIS! I just log off and go sulk somewhere…

Prologue: Boruta

During the week, we did Boruta at Sulivinas Lair. Frankly, I don’t get how people manage to kill the dragon so fast with this bug plaguing the game for weeks now. On Monday, we started the instance and half those who joined couldn’t enter the f*cking area because the game tried to put them in a different channel, which of course doesn’t exist in this case. So yeah when the portal opens and you find out there are only three people in the cave and the others either coudln’t enter or left, and you cannot restart the mission so you both lost a day and the time wasted that day. SIMPLY… GREAT…

Epilogue: bug report

Time to make a bug report then. I’m surprised no one reported this already, because it’s quite severe.

“Hello @draconis
Kindly send us a support ticket so we can investigate your concern.
Thank you”

Hmm… why do I have the impression of every bug report I make is like a piece of toilet paper that gets flushed without any concern whatsoever? Oh yeah… after sulking for a couple hours I went back to the web site and checked all the bug reports I’ve made in the past weeks (there were quite a lot too). Nice… they have been all answered, let’s see how many they have fixed.

#1: “as a workaround, edit some xml files in your client’s directory”


#2: “please verify files integrity”

Err are you sure, my files are feeling well, doctor…

#3: “try to remove any add-on”


So yeah about me making another support ticket, I’d rather go s*** a d***! These bugs are so flagrant there should be no need of support tickets if there was a testing team for the game. In the meantime the announcements for more TP packages continue… I think you should revise your priorities first, because satisfied customers come back for more, unstatisfied customers go see elsewhere. And your trying their patience REALLY hard…

And that’s it for this rant. I hope this was more useful than a support ticket, at least it helped me release the steam.


I feel you there…this issues was gone so lonmg and came back at one of the most worst times possible! Everything takes longer than it should, my daily routine for this event should not take longer than 4 hours, but on really bad days I am happy to be finally done with it in 6 hours and well that’s usually all the time i got for the game daily which his freaking annoying :cricket::cricket::cricket: