Tree of Savior Forum

Returning after a while -> team name problem

Hello,

I’ve return after a while. When I tried to connect to Fedimian server the game is asking me to create a new team name. But I already had one ?

I even can see my caracters in the back ground of the lodge. !
team|690x373
When I try to enter my team name it say the I used not allowed caracters. “Nereid” is the name I entered. So I can’t see what part is not allowed.
What’s the matter ?

About your name being gone: a while ago imc did a wipe of all accounts that hadn’t logged in a year or so, and blanked all their respective team names, so they’d become available again for other players. Not sure about the “Nereid” issue, but if someone else took that team name then you’re out of luck and will have to choose something else.

Ok thank you for your answer. I’m going to try a new team name and see if I can access my caracters that way. But what team name that another problem x)

1 Like

Ok it worked. It was pretty simple x) Thanks again !

Congrats :satisfaction: