Tree of Savior Forum

[Resolved]Class Advancement Screen Bug Has Been Fixed

Link to Picture/Screenshot

This is a snapshot of what happens to my screen after clicking the advancement button. I had reached level 15 normally and clicked the advancement and this came up. I have tried relogging and completely restarting the client but no luck there.

Class is Wizard
Server Klaipeda
Name: LacusKlein

Edit: The Devs have stated that this as a known issue.
3. Unable to advance in class
We are aware that some of you are experiencing problems when trying to advance in class. The dev team is currently looking into this and an announcement will be made as soon as the issue is resolved.

Hopefully it will be resolved soon.

Edit 2: From IMC
Greetings, Saviors. Many users were unable to advance their job classes because of a bug in the UI projection. This was due to a defect in the output of our UI coding. We have fixed this issue, so you should be able to proceed with your advancement now. The change will be applied once you move zones or reconnect to the game. If you face the same issue again, please report it on our forums or through support tickets. Thank you. Best regards, IMC Staff


me too.

Class is Wizard
Server Orsha
Name: xLee

Yep I have the same problem too. So at this point I’m stuck at Archer 15 while my character level is 26. I’m on Klaipeda as well

Team Name: TheRelentlessOne
Character: Aros
Class: Archer
Server: Klaipeda

me too. I am a swordsman on Klaipeda, I can’t rank up as well.

class: swordman
server: klaipeda
name: Asterion

i have the same problem
server: klaipeda
Name: Madao

me too :’(

class: Wizard
server: Klaipeda
team: SunnyZ
name: Vanellion

I’m also having this problem, exact same thing in the screenshot.

Class is Swordsman
Server: Klaipeda
Name: Poofy
Team Name: Kitouski

:C mee too :C

Class Wizard
Team name: Krausser

Yea… i’ve been having this problem from the beginning myself, tried to reinstall etc…
Server: Klaipeda
Name: Gazso
Team Name: Mayosin
Class: Archer

Was heading to Archer c2.

Me too…
Server: Klaipeda
Name: SirLight
Team Name: Whitehalf
Class: Cleric

Server: Klaipeda
Name: LaMaga
Class: wizzard

Me too
name: Menuki
Class: swordman

Same here:

Server: Klaipeda
Name: Crowllie
Class: Swordsman

I already used my TP points and bouth cash custom cloths, i cant delet this character.

same issue

Class is Wizard
Server Klaipeda
Family Name: Negi
Character Name: GMO

One more here!

Server: Klaipeda
Family Name: 29iA
Character Name: Caffry
Class: Bowman

I already used cash, TP, to buy custom cloths, create a new char isnt a option, please solve this problem, we’re counting on you IMC! <3

same there

Yep me as well.
It was my main character so i give it all the premium items and got it the tp costume. I cant delet it now and we dont have the noob class like in ro here .

Swordsman TP cash, Custom Cloth.


Archer 15/15 can’t click on advancement
Arashi Hitsuzen