Tree of Savior Forum

[Quest] Epherotao - Destroy the Massive Kruvina (2) not completing

Date and Time: May 27, 05pm server time

Server Name: Silute

Team Name: Wellan

Character Name: Manolete

Bug Description: Quest - Destroy the Massive Kruvina (2). Cannot complete the quest. After killing the boss that spawn, there is no automatic trigger, or even an item, place or NPC that I can interact with to complete the quest. Abandoned and tried 4 times already.

Steps to reproduce the issue :

  1. Get the quest
  2. Reach the place in the map where the trigger starts the cinematic
  3. Kill the boss
  4. Get stuck

Screenshots / Video:

Just to clarify: this problem occurred in March? And when you tried to complete the quest now, you are still facing a problem?
Or do you mean the problem started in May, this month?

interact with the crystal, it’s a bit hard to do in keyboard/joypad so try switching to mouse mode.

May haha

My bad


Ok, gonna try it. It is weird cause I tried to find a spot that allows me any interaction, but couldn’t find any

EDIT: done! Thanks @Lostac

This bug is still a thing… i cant interact with crystal in any control mode @STAFF_Letitia

I tried to kill this boss away from the Kruvina as much as I could. I found that zplus angle was not allowing me to interact properly, so if you use it, it is a good idea o run /zplus reset before entering the quest cutscene.

Mouse mode will help too, but I did another attempt recently and I managed to interact with the Kruvina on keyboard mode.

Hope you can finish this quest!

The only quest that I am missing out is the hidden pillar at Galeed Plateau. None of the times on onther posts are matching for me… this pillar simply does not appear to me :confused:

1 Like

ill try without any zoomy angle/zoom and see what happens

ok, reseting zoomy to default settings fixed the problem. There was no problem interacting with crystal even with kb mode

Thank You very much!

1 Like

If you have zoomy plus, try reset settings then change channel. Redo quest and see if you can. A lot of quests from rank9 content showed this issue for me, where the zoom (or rather overlapped layers) do not allow me interactions

Doesn’t work for me. I don’t have zoomy or any other addon. I’ve sent a ticket to the support for them to investigate the issue.

That’s because the pillar doesn’t appear at fixed times. It’s the same problem you face when doing the Runecaster unlock when talking to the Chronomancer Master: the timer starts when you enter the area and resets if you leave.


  • you enter Galeed Plateau
  • a 2 hour timer starts
  • when it reaches zero, the pillar appears
  • the pillar stays for 5 minutes and disappears
  • a new 2 hour timer starts

The pillar would appear every 2 hours and 5 minutes if someone stayed permanently on a channel in that area. But once there are zero players on the channel, the timer resets.

Solution: enter the area, complete all other quests (it takes some time, especially since there are some that don’t appear immediately – you need to trigger certains events or click certain objects), then wait for the pillar to appear at the designated area. If there was someone else in the area when you entered, the timer may be way shorter so you still need to be careful and not miss the pillar.

1 Like

August 22, 2019. still having this problem it seems.

December 20, 2019 and the problem still exists.