Tree of Savior Forum

PS4 controller not working any more

Please fill in as much as you can :

Date and Time(Please, specify the timezone) : GMT+8

Server Name: Telsial

Team Name: Crumbleberry

Character Name: Various

Bug Description :
Cannot use my ps4 controller to play TOS from Steam. The ps4 controller is connected via bluetooth, and can work with other games in Steam or in windows. I used to be able to get the ps4 controller to work in the same way, but now cannot seem to do so. I dont remember doing anything differently.

Please help me!!! :3

Steps to reproduce the issue :

  1. Connected the controller in Steam, when starting TOS, select Controller instead of Mouse, the UI changes but the game cannot detect the controller T_T

Screenshots / Video :
Nil

Game Control Mode (Joypad) :

System

  • CPU : Where… do I find this?
  • RAM : Ehh… good enough?
  • Graphics Card : GTX 1080
  • Mainboard :
  • Storage :
  • OS :
  • Internet Connection : 3gbps
  • Country, Region : Singapore

It is not working anymore. This include nintendo switch pro controller or any d-input controller. One way is to plug usb to your ps controller.
Other is, switch on your controller and steam first and make sure steam detect your controller. Then, open tos game. This is working 50/50. Once you lost power or plug a usb into it, then u need to restart the whole process again. And again, it is 50/50.

Just plug the usb cable and be done with it, since if you disconnect the cable, it still can detect back once u connect the cable.

This problem only occurs with d-input controller, so xbox controller work well with the current client. Possibly because they change the api since the client move to direct11 and causes bug. Ps4 controller via steam is emulated d-input.

I use switch pro and xbox controller, but end up plug in the usb cable to the xbox controller because xbox controller for windows have another separate unrelated bug and I’m so done figuring fixes.

1 Like

Omg really? They broke the controller support? :3

I haven’t tried using the USB cable because I didn’t had to previously and connecting wirelessly looks cleaner too.

Bummer… hope they fix this…

no, the problem come from steam with new updates they always appear one windows saying you need use mode big picture for control support full… so you need use big picture, go to control setting, click control autodetected, click preferences and rename and save for refresh ur configuration then start tos and minimize big picture and play, i usually make that if u have pc without details of energy we work i hope u get help with this.

1 Like

Ya, I did that actually but cannot get the controller to work.

I use that fix too. It fixed the issue but currently, this fix is not working anymore. So, I ended up with wired mode. Works all the time.

1 Like

Try to open steam as administrator, that the way I can use my controller since some “updates”

2 Likes

Download a program called DS4 windows. Go to ToS page in your library, top right there is a ‘cog’ icon, click that and go to properties. First thing disable ‘steam overlay’, go to gamepad tab of the same page and disable everything.

Close ToS.

Run DS4 Windows as admin, it will make the system think you are using an xbox gamepad.
Use default profile, or change mapping according to your liking. Go in, try it out.

The only thing is IDK if DS4 windows works with Blutooth connection. I use mine wired.

One other issue is ■■■■■■■ Windows 10 making a mess with your gamepad driver. It oftens recognizes that as headset too. Before trying anything, go to ‘Devices’ in the control panel, look for the controller’s icon and see if it’s not on ‘Error’. If so simply click ‘remove’ then reconnect the controller and give it a try.

1 Like

Thank you! Running Steam as administrator seems to enable my controller via bluetooth!!!

1 Like

Thank you too!!

:haha:

1 Like