Tree of Savior Forum

Problem with game controller joystick - after patch

Same here in my PS4, Pro Controller Switch and Xbox One joystick.

The following steps fixed it for me:

open steam app, on the top left option list, click:
steam > settings > controller > GENERAL CONTROLLER SETTINGS

if you are using PS4 controller, check the ps4 controller box (etc for others)

on the bottom, the detected controller should show your controller, click on it.

click on identify and then click calibrate. choose complete auto calibration

follow the instruction and complete the calibration. now the controller should work fine for ya.

1 Like

The calibration did not work for me. Everytime I take an action he runs straight for a slit second and i cant switch targets.

Hmm, I don’t see a problem on mine

By chance, are you guys using wireless? I’m using a wired Xbox360

That fixed it for me, thanks. For some reason, moving and jumping in a diagonal became much harder though, but guess I’ll have to get used to it.

this explains why I would complete the rainbow track in 3 minutes and today It took me 15. I thought I was the problem but the directions kept changing every time!

Also try this, alt tab from the game and back to it.It takes the game a second to detect the gamepad again ( PS4 Joystick).

I have this problem too… I actually thought it is lag… before I tried it with mouse/keyboard (unless controller-specific lag can exist)… It affects my wizards the most and I guess would affect my archer… so basically ranged stuff…

Mostly I don’t have a problem even when I attack nothing there is no problem but when I attack a monster and I try to move around during/after it… it rather starts to move in the last direction that it was recognising and make a few steps and during that I can’t control my character…

I thought I have a massive lag with my Onmyoji yesterday during challange because my character was uncontrollably running around but it seems like I didn’t… So it even affects aoe skill usage badly I guess…

This part for some reason is non-existent for me or my generic controller xD… also for whatever reason I tried to set the buttons in the window that popped up… xD but something is either wrong with my controller or steam doesn’t like it because I had to reinstall steam because of it… All that i learned from this amazing experience that I have no idea how steam works and why wasn’t there a reset button for my ■■■■■■ up settings xD… I don’t want to touch it again lol…I’m lame…

I solved my problem after testing a lot of things.
The file “hotkey_joystick” in tos folder looks like its the problem, i think. I edited him because the buttons got swaped for no reason, and, this delay problem dissapeared o.o

Can you share us your edited file? It’s really annoying to play with those problems

Sure, HERE the file. Tell us if worked. Remember that this can change ur buttons order.

I always had an edited one and actually after the patch I had to replace it. So the patch did affected that file… but doesn’t matter how I replace it or verify the game files to get the original… I still have the problem… :confused:

Yours doesn’t work for me either ( and also not good for my buttons…they are weirdly swapped with yours too XD )

I think the last thing I’ll try is to verify the files again and try to compare the original one with my old edited one if I see something different…

I’m not sure why for some ppl the issue gets magically solved but nothing works for me and my lame little controller… I should send in a ticket later but I’m not sure if IMC will acknowledge the problem…

Aw LOL… I found the cause of my problem…

I have no idea if this is a magical solution too or works for others too…

But actually my alchemist didn’t have any problem and I didn’t get why first… then I checked the settings…

After I unchecked the “Controller Vibration” in the settings it works fine again. My controller can’t even vibrate afaik…

Also as I said I used an old edited xml file I had… and it did change with time… don’t know if with this patch or an earlier one tho… but I rather updated the new one to my settings ( but that rly wasn’t what solved my problem )

Well… I just can’t play like this lol

My character is almost a pro in ski ballet because it can’t stop sliding through the maps.

No word from staff? @STAFF_Amy @STAFF_Ines

I like you Amy and Ines, please don’t let me down!,

Just show me a way to get one my controllers working correctly! (Xbox 360 or PS4, does not matter T.T)

the fix presented by @flyawaychen solved the issue, did you try it?

Yup, no luck here. So sad

I already had this problem long before the patch, so I guess it got nothing to do with steam but is in fact some client-based problem in dealing with hardware.
All 3 of my controllers have different amounts of the same issues, but no issues whatsoever on any other computer game.

That’s “partial” controller support for you :slight_smile:

1 Like

Coming here to say that uncheck the “Controller Vibration” option in the settings solved my problem and for another people too. Thats why when i put an old version of the hotkey files worked, because it didn’t have this option checked.

Adding my hat the pile. Toggling controller vibration fixed it for me.

Along with Calibration, another option from google that worked for me was changing controller deadzone crom Cross to Square. Credits goes to a person from Klaipeda shout but I forgot their name D:

Make Steam detect and setup your controller by enabling it on Controller Settings. For generic controllers you should map the buttons before next step.
Find the Joystick settings and change its Deadzone from Cross to Square.

If you have swapped buttons (like O being swapped with X etc) you can also open Big Picture mode and ToS -> manage game, then edit it there instead of in the hotkey_joystick.xml file. It should be easier and the buttons won’t be swapped back after a maintenance or anything.

A better guide on how to change the joystick’s deadzone into Square:

also had the same problem, when I took the option of vibration the control returned to work quiet again.