Tree of Savior Forum

$NoData$ Text at the Start Screen ! :(

Guys, I recently installed the game for the 2º CBT, but when I start the game the text of everything contains $NoData$UI

I already tried to fix the game by deleting and reinstalling the game and fix in steam at Steam>Proprieties>Local Files>Verify Integrity Cache.

(btw: I know that the game wil only be available Oct 27)

Thanks in advice !

Wrong section.


Go to C:\Program Files\Steam\SteamApps\common\TreeOfSavior\release and Delete (Or just Ctrl+X just in case) the “languageData” folder and re-download it with the Game Patcher

I’m sorry, in the case, which is the right section for this kind of post ?

Well follow what @Nyuha said and it should solve your issue.

If you have a similar issue in the future,post it in the Bugs section.

Nyuha, removed the “languageData” folder as you said, but the Game Patcher did not re-downloaded nothing, I can start the game again, but the issue continues.

Alright, thank you ! :smile:

1 Like

Hmmm, how about these two Files at C:\Program Files (x86)\Steam\SteamApps\common\TreeOfSavior\data : language.ipf and ui.ipf Try the same thing

No luck, I deleted the language.ipf and ui.ipf, the patch Re-Download it, but the languageData folder isn’t.

(I also tried to put it back after re-downloading the language.ipf and ui.ipf, but the luck too)

I managed to fix it !

I was looking the ToS Folder when I was trying to delete the game, and I noticed that the “Release” Folder was still there with a few things, then I deleted it and re-downloaded it, after that game texts was fixed !

Thanks for the help, Nyuha !


I will try it :slight_smile: cause i got no luck deleting the folder too

replace the text that is similar to this in ur user.xml that can be found here:

<Sound TotalVolume="255" SoundVolume="255" MusicVolume="50" Language=""/>

i fixed mine with this one :smile:

Hey I need help with it please,

  1. Login to the game
  2. Open the System Settings ingame
  3. at the Bottom select another language

That should solve the problem.

Kind regards

Uhmm hello siegnier can u help me with it ? same problem bro i just wanna ask if u deleted the folder ‘release’ or u just deleted the ‘languagedata’ ?

hello nyuha i have the same problem as siegnir do i need to delete the folder ‘release’ or just language data, language ipf and ui.ipf only ? pls do reply it will help me a lot thanks !