Tree of Savior Forum

Is Res Sacrae: Blue Fortress Dungeon bugged?

Since yesterday, I didn’t see the elevator to reach the first fights of the dungeon. I decided to wait for the patch notes and the maintance but I saw noone posting about it in the forum. Am I dumb for noticing something to trigger the elevator or just dumb to play Tree of Savior?

The elevator is broken. You can use Wizard Teleport if very precise to clear the dungeon. You can probably use Sage blink too.

1 Like

Welp, I’ll lose my resets from last week then. Thanks for answering, @crevox

Dungeon is not bugged did it already, first elevator is on the right of starting area and for last fight the gimmick is in the middle of the big circle room I think it appears only after killing rest of mobs.


Here,@ereborn? I’ve waited for 5 minutes and gave up

1 Like

It has been bugged every time I enter. The elevator at the start doesn’t show up and there is nowhere to go. I actually soloed the dungeon and completed the entire thing by teleporting past it, and for the full 30 minutes duration of the dungeon, the elevator never appeared for the other party members.

I’m having the same problem with Res Sacrae since yesterday night (Monday, 08 Feb 2021). I was able to complete one single run, the very first time I entered the auto match queue. After that, I tried it 10 times or more, and was never able to see the platform to exit the starting area.
I also entered in an auto match run and stayed there for the 30 minutes of the instance, waiting for it to fail and maybe “clear” the bug, but it was not successfull.

Can someone please help?
If anyone get to clear this, help us.

Thanks o/

This bug existed already when this dungeon was a dungeon…in ancient times xD… and it still exists…lol

It maybe has something to do with the current bugs/server issues tho… I don’t think you can do anything against it… you either lucky and it’s there…or not…

1 Like

I want to post an update and say that after more tries, I did manage to get the elevator working once. So it does seem intermittent.

Tried and worked twice so you guys can try this out:

Before choosing buffs, go near the edge where the escalator appears first to make it show up. It seems like the escalator disappears after the buff selection window disappears. Make sure at least one person rushes to the edge asap.

For some reason, this doesn’t work anymore. *sigh

1 Like

i have sage with max lv teleport and blink. but it too far

Indeed, sometimes the platform is there, sometimes it isn’t. Right now it’s just about retrying until it works.

But you need the chat to be working to try since it’s automatch only soooo…

Could put a portal at the beginning would solve,
Is there a weight limit on elevator?

No, my summoned Zaura is a heavy guy and he’s fine.


but isn’t your summon a shadow and thus weightless?

i submitted a ticket, hopefully they’ll fix it soon


This is pretty much the fate of everyone that pre-emptively bought all 10 of their Res Sacrae resets (2500 Merc x 10) early on in the week.

I managed to finish 1 out of the 2 weekly runs (somehow the elevator spawned for us) and never got around to using the resets. I tried to queue when there were Sages shouting but never made it in with them (got into a 2nd or 3rd group of people probably hoping for the same matchup).

Take note, that one successful run happened after I’ve queued for like 17 times this past Sunday evening (SGT).

1 Like

This elevator is bugged util it was released (I don’t remember… 270 dg maybe?)
I really dont understand why they recycle this bugged dungeon…

because they dont have money to create new dungeon
or even check before they recycle ■■■■
worst thing is we get blue fortress dungeon again this week
unless they reset it to another after patch, we are pretty much fkd again this week
not only getting into queue is troublesome, now this elevator bs that not even mentioned in patch note

:joy: :rofl: :joy: :rofl: :joy: :rofl: :joy: :rofl: :joy: :rofl: :joy: :rofl: :joy: :rofl: :joy: :rofl: :joy: :rofl: