Tree of Savior Forum

In-Game character portrait replaced by wizard symbol

Server Name: Daiva

Team Name: ToughBunnies

Character Name: Lysaera (but also occuring with my other characters)

Bug Description :
Screenshot says it all : in the top left corner, instead of seeing my character’s portrait I just see the wizard class logo. I tried repairing the game files in Steam, but it didn’t change anything. Issue is still occuring after today’s maintenance as well. I can see the portraits just fine while in the Lodge, problem only occurs in-game. UI mode doesn’t change anything.
I’m not sure when this started occuring, I just noticed it after playing for a while about 2 days ago. I was not doing anything special and did not get any error messages.

Steps to reproduce the issue :

  1. Log in and start game on any character.

Screenshots / Video :
(attach screenshots or videos regarding the bug)

Game Control Mode (Keyboard/Joypad/Mouse) :
Mouse but tried changing with no effect.


  • CPU : Intel Core i7 (7th Gen) 7700T / 2.9 GHz
  • RAM : 8 Go
  • Graphics Card : HD Graphics 630
  • OS : Windows 10
  • Internet Connection : As good as can be when everyone is using internet, being confined.
  • Country, Region : France

Not a bug, it was changed a while ago.

You can change the icon to any of your classes, by clicking the little gear icon in the F1 menu.