Tree of Savior Forum

Destroying obelisk quest error

Please fill in as much as you can :

Date and Time(Please, specify the timezone) :
5/12/2021 1:26PM GMT+7
Server Name:
Team Name:
Character Name:
Bug Description :
(letting us know what you were doing before, during, and after the bug happened will help us a lot)
Did story quest in a group with my sister and mine stuck at obtain the explosive to throw. Tried log out/exit/etc but still stuck. My sister doing fine can obtain the explosive and throw it. My quest still not progressing even my sister already did it. Try disband the group but still stuck
Steps to reproduce the issue :

  1. Do story quest with someone else in a group
  2. Progress to destroying obelisk until done placing explosive and can not obtain explosive to throw
  3. Other character in group can progress by obtain the explosive and throw it at obelisk to destroy it
  4. The end

Screenshots / Video :
(attach screenshots or videos regarding the bug)

Game Control Mode (Keyboard/Joypad/Mouse) :
xbox controller and keyboard mouse


  • CPU :
  • RAM :
  • Graphics Card :
  • Mainboard :
  • Storage :
  • OS :
  • Internet Connection :
  • Country, Region :

Greetings BonBonCat,

Kindly submit a support ticket with the details of the matter for further investigation.

Finally it’s fixed after abandoning the quest