Tree of Savior Forum

Controller stop working whenever I open another game

Due to the AFK events and most farming content being limit. I began to play other games with Tree of Savior open.

Whenever I start to play another game and go back to ToS, my controller stops working on Tree of Savior but it continue to work on other games. When it happens, I have to restart my Steam otherwise my controler won’t work on ToS. Even closing and launching the game again doesn’t work. Would anyone know a solution for that or is it intended? I have some suspicion it happens because of the old cases of multibox though but I don’t have proof.

Thanks in advance for any reply.

A little extra note, this happen with any games I try to play with ToS open from Steam, even those I don’t use the controller. The only game this bug didn’t affect was a non-steam game.

have you tried unplugging the controller and plugging it in again or using the reset button on the controller (if it has one)?

I noticed that the controller authentication of the TOS client seems bugged ever since the last big update, sometimes I can only use the controller if it was plugged in before I started the TOS client and won’t work until I close it down and open it anew with the controller already connected, and sometimes I can, like before the patch, just plug in the controller while the client is already up and running.

I tried it. If I plug the controller while the game is running, my controller won’t work too. The only thing that works so far is restarting steam to use it on ToS.

Make sure you have steam overlay disabled. Beyond that, I would try moving with the keyboard for just a moment and then trying the controller. Both of these things can resolve it.

1 Like

if you’re using an xbox controller press the xbox logo button in the middle … works for me …
or if all else fails ( this is for my xbox ) and as Crevox said … Uncheck the Steam Overlay …

  • Go to steam
  • Settings
  • Controller
  • General Controller Settings
  • Check (Guide Button Focuses on Steam) and (Xbox Configuration Support)
  • Click Detected Controller
  • Preference
  • Submit

A popup would show saying the controller is active … you can do this while you’re ingame ToS …

1 Like

I have problems with my ps4 controller too, idk why because I played the game with it in the past and I didnt remember that I had a problem. I normally connected it and no more. But now I cant play with it, Im not sure how to fix it I tried everything you said here :sad:

PS4 controllers are no longer supported by TOS, already for quite some time (it was at some point in 2020 when support ceased iirc).

The game should still support XBOX and Nintendo Switch Pro controllers

Edit: @Alyu_support

XBOX 패드 이용 시 ALT TAB 또는 ENTER를 누르고 다시 움직이려고 하면 일정 시간동안 패드 사용이 불가한 문제가 수정되었습니다.

If your problem was with an XBOX controller, the recent KTest patch states it as fixed ( controller stops working after Alt+Tab or Enter)
now it’s a question of time how long this will take to hit iTOS I guess?

2 Likes