Tree of Savior Forum

Class points are not being rewarded


#1

A guildmate complained that he was not getting class points to change his class and I tried a few methods to get them. Level Dungeons and Saalus are not rewarding players with those points while Mercenary Dungeon, Fishing and Login are. I’m unable to test Uphill, Unique Raids and Legendary Raids at the moment so I wanted to post it and check if anyone who did them get any point.


#2

Did you wait until the last second to see if you were getting the points? Like for example, if you quit early from the Level Dungeon you won’t get the Re:Build Coins. Same for the Saalus red cubes.

I’m unable to test it out because I saved points from the last day of the event, so I’m all maxed out.


#3

I didn’t stay at the very end on the dungeon and saalus, but I stayed around 30 seconds on both.


#4

From what i noticed my Inquisitor isn’t getting points for dungeon runs (and also has UI bugged with map locked at start and no completion rate), haven’t checked other characters.


#5

Im having the same issue, im receiving only the login points. Im not getting 5 more for using token and didnt get any from dungeons or salus. Team name is Vethathis.


#6

I also suffer from that bugged and not updating UI.


#7

Anybody can explain why i get no class change points for completing 330 dungeon?? Is it because i go with a 360+ character?


#8

As far as I know, all dungeons should give you points despite the level required to do them.


#9

I noticed im getting points from dungeons on new characters i made in my account, but not the ones i had previously. I cant test with all my chars, but at least from the old ones, two that i changed class tree dont get class change points from dungeons.


#10

This post was flagged by the community and is temporarily hidden.


#11

The problem is that with the characters i tested that were class tree changed i dont get any points at all for completing dungeons. Only the login points (didnt tested other ways to get point tough). I do 100% everytime, i tried soloing, i tried with a party, but got the same results.


#12

Oh and with the characters i made recently (two of them) i get the points at the end of the dungeon normally.


#13

This post was flagged by the community and is temporarily hidden.