Tree of Savior Forum

Cant put gems into armor/weapons

Please fill in as much as you can :

Date and Time(Please, specify the timezone) : August 1, 2019/11:44AM/(UTC+08:00)

Server Name: Telsiai

Team Name: Zepiroth

Character Name: Innocentius

Bug Description :
After getting back to TOS after a year, i can’t seem to put gems to my armor or weapons (with socket ofcourse). I also tried giving the gem and weapon/armor to my alt but the same thing happens, still cant put the gem to my equips. Please help, i really want to get back to the game. :frowning:

Steps to reproduce the issue :

  1. right click the gem
  2. click yes to “extraction etc.”
  3. Equipments with sockets would get highlighted.
  4. Try to left click the gem into the armor/weapon but it would just stay highlighted and not get in the item.

Screenshots / Video :

Game Control Mode (Keyboard/Joypad/Mouse) : Keyboard

System

  • CPU : Intel i7-6700hq @2.60ghz
  • RAM : 8gb
  • Graphics Card : NVIDIA GTX 950M
  • Mainboard :
  • Storage : 930gb
  • OS : Windows 10
  • Internet Connection : DSL
  • Country, Region : Philippines/SEA
1 Like

transfer gear and gem in team storage then use other character to equip gem can?

sometime only char is bug

1 Like

Tried doing that but still can’t put gem into the equipment :(((

1 Like

would u mind post ss of equipment and gem?
maybe have warning msg popup say u might missing something

1 Like

it will just move indicating that the item has been clicked, but the gem still wont go in the item.

%E0%B8%A0%E0%B8%B2%E0%B8%9E
no system msg like this display? @_@

then probably is bug i think = =’

Yea, no message like that. If it is indeed a bug, i hope the devs can see this :(((

1 Like

@STAFF_William @STAFF_Bob @STAFF_Yuri please check this case @_@

1 Like

Imc wont do anything or give you any usefull help. I have the same problem, give your account to a friend who does not have the problem and ask him to help you

Are you using any addons? I had this issue until i temporarily disabled all my addons, and then i could insert gems normally.

2 Likes

ah yea, try disabling/deleting addons first and see if it’s fixed, addons cause problems sometimes

2 Likes

Thanks for this. It seems removing ALL the addons did the trick. <3

1 Like