Almost frequent VGA error


#1

Date and Time(Please, specify the timezone) : March 12th

Server Name: Fedimian

Team Name: LifeSupport

Character Name: Zachariel

Bug Description :
I just get a VGA error out of nowhere, mostly in Klaipedia, but I got it in Challenge Mode, Gemstone Feud, and sometimes at any map. I’ve been getting this error this past 3 weeks but it wasn’t frequent, but after the new patch, only today I got already 4 VGA error. I reinstalled the game, I don’t have addons, I have the lastest version of DirectX and video controllers, I checked the files integrity and I always get the notification that 4 files couldn’t be verified and steam ends up downloading them, but that doesn’t fix anything.

Edit: Also sometimes my game just closes by itself, no error message or anything, it just closes, it happened last saturday, yesterday and today

Screenshots / Video :

Sin%20t%C3%ADtulo


#2

try check this thread it had some tips


#3

That’s because the game deletes them when you launch the client… You have to make these 4 files read-only and you’re good to go. However, I doubt this fixes your VGA problem, it’s just a bug you’re encountering and could be caused by anything.


#4

yeah, those tips didn’t help, I still have the problem


#5

yeah fixing those files doesn’t help at all, even the developers don’t know what causes this problem since a lot of people had this problem before, it’s not a new thing, and it keeps appearing from time to time in this forum


#6

Have you tried checking the versions of Visual C++ you have installed?

Try the steps below runtime error here

https://treeofsavior.com/page/guide/view.php?n=36


#7

what’s your character build?


#8

Make sure you have no items with animations equipped, I know several people who have been vga’d by the Giltine’s Armband, im assuming it can happen on other items aswell, I know of atleast 1 person that had the same issue with an effect costume that had an animation.


#9

I’m sad to tell you that this VGA plague has striken me yesterday too :frowning:
Got 3 VGA errors in my first hour of playing, one in Irredian, one in Saalus, one in fields. I’ve reported a problem where my game turns into a polygon display after some time, so I guess there’s a memory or reesource leak somewhere that could be the cause of it. Maybe this causes VGA too who knows, but there’s clearly a nasty bug hidden in the latest patch.


#10

Hmm about that… one of my chars found a Long Armband recently, and I remember a bug some time ago with that item. I’ll try to remove it and see if that changes anything.


#11

I am having alot of VGA problems here farming in fields… maybe the problem is falconeer? idont know


#12

I have falconer/hunter, and I can tell you falconer it’s not the problem, the multi-hit animations can give you lag, but it doesn’t trigger the VGA error


#13

I have the 2005/2008/2010/2012/2013 and 2017 installed


#14

have you tried updating your video card drivers? had some artifact problems after recent patch which was solved by updating drivers.


#15

i think it is about the equipping stuff with animations now that you mention it

most of my chars that went VGA are ones with animated equips such as

shadowmancer accessory
long armband
giltine armband


#16

Most of my chars wear the “Long Armband” (found some farming “Dratt Twohand Sword”) and I didn’t have VGA errors. But maybe in conjunction with other things like CPU (i have intel) or graphics card, the armband may still be the cause.


#17

i also notice how mine usually occur when i try to chat Owo;


#18

I confirm that the Long Armband doesn’t provoke any VGA errors or graphical glitches. For the glitches, it’s due to using some pyromancer skill, probably Fireball, which has a graphical ressource leak, so after a while all the graphical ressources are eaten and the game cannot continue displaying effects and just draws empty polygons.


#19

well i thought that was falco, because i played with my lancer and didin’t happened, however i was only doing quest with him.

playing with my falco i had 3 vga error in one hour inside HG before the path, that’s really weird.


#20

This is getting annoying. I have been getting these VGA error too after the latest patch.