Tree of Savior Forum

64Bit Lower FPS?

Hi, I was wondering. When I play 32Bit in ToS I get around 120+FPS, but when I do 64Bit I only get 44+FPS. My laptop monitor says its 144Hz with 3ms. Do I need to do something for it to work properly?

Thanks,

can be alot of things , cant help you so much, you have 8+gb ram? try lower resolution and off sync option in setting ingame.i start with that.

1 Like

It has to do with one recent update. Before that I was at 75 FPS (I’m using vertical sync so the max is adjusted to my monitor’s frequency which is 75 Hz), now it’s 40 FPS, but I didn’t change anything on my computer. Probably one of the new options that doesn’t work properly (there is a max FPS cursor somewhere that is set by default to 30 or 40, but moving the cursor to the right up to 120 doesn’t change the FPS so it’s probably bugged).

1 Like

Hello, thanks for that. Yeah I have 16gb memory. First I thought my laptop is just slow for this game to reach at least 100 frame/sec, but I tried other games and its working much smoother with 144mhz refresh rate, so now I’m just confused. 32bit uses less memory than 64bit so I’m not sure how it gets worst lol!

make sure the game is using your dedicated graphic card, for some reason, some people are complaining about having their integrated gpu enable when you use 64bit

1 Like

good one, can be that

1 Like

Oh wow, how could I check this one? This might be the reason because its a Laptop.

I only know how to enable nvidia’s gpu. Just enter nvidia control panel, click on Manage 3D Settings, Program settings tab, then proceed to add Client_tos.exe (C:\Program Files (x86)\Steam\steamapps\common\TreeOfSavior\release), on that page, go to the 2nd tab and select ‘High performance Nvidia processor’

1 Like

I see the problem now and I can’t believe how I miss this for a long time. When I use my Laptop Monitor it uses the Integrated GPU (CPU Graphics) but whenever I connect another Monitor which I have been doing it unlocks the Dedicated Graphics. And the Laptop Monitor is the one with the 144mhz LOL!

Thanks for this,

Just to add, this is nvidia optimus function switch on by default on every laptop (typically). Even you set the program to use nvidia graphic, the output still go through your integrated gpu. Therefore, your fps still capped and low than it should be because of your cpu intergrated graphic. Only some brand and gaming model can use laptop monitor direct connection to nvidia graphic like lenovo legion or asus zephirus. So, the usual way with any laptop when gaming time, is to buy a good gaming monitor with same resolution as your laptop to bypass optimus.

Below is some list of gaming laptop than has the mux switch.

1 Like