Tree of Savior Forum

2nd Demon Prison, Spell Suppressing Crystal bug

Please fill in as much as you can :

Date and Time(Please, specify the timezone) : 1/8/2020 4:14pm CST

Server Name: Kalpedia

Team Name: RiverDevils

Character Name: Akuma

Bug Description :
(letting us know what you were doing before, during, and after the bug happened will help us a lot)
I am in 2nd Demon Prison trying to complete the map and get the collection box.

I reached the Confined Firent but I couldn’t kill it. I looked it up on the forum and youtube videos and it seems there is a bug that is preventing the Spell Suppressing Crystal from working. I see it there, I see where it says ‘space’ to interact with it, but nothing happens. If I continue to try to interact with it the Firent eventually reaches me and destroys the crystal.

I have backtracked through the portals. I have left 2nd Demon Prison and gone back to Shallot Reservation and returned.

I went back to the Confined Firent and tried to interact with the Spell Suppressing Crystal again. Nothing.

I left 2nd Demon Prison again. I come back and then interacted with the Unstable Spell Seal Crystal then made my way back to the Confined Firent and tried again to interact with the Spell Suppressing Crystal but nothing.

I can’t get the Spell Suppressing Crystal to work at all. It definitely feels like a bug.

Steps to reproduce the issue :

  1. Reach Confined Firent area
  2. Try to interact with Spell Suppressant Crystal
  3. Nothing works

Screenshots / Video :
(attach screenshots or videos regarding the bug)

Game Control Mode (Keyboard/Joypad/Mouse) : Keyboad

System Lenovo Y50-70

  • CPU : Intel ® Core ™ i7-4720HQ CPU @ 2.60Ghz
  • RAM : 8.00 GB
  • Graphics Card : Intel ® HD Graphics 4600 NVIDIA GeForce GTX 860M
  • Mainboard : Intel Core i7
  • Storage : 1 TB
  • OS : Windows 10Home
  • Internet Connection : Wifi
  • Country, Region : USA

Don’t you need to kill a red goblin to access the collection area? Otherwise simply use a wizard and teleport there.

I am so happy someone is checking the old gimmicks, this one is interesting and a pain. The crystal needs charge and monsters can destroy it. So the objective is to keep the crystal safe while it charges (there’s some visual feedback) then keep it safe while you use it (it takes a few seconds).

Now i am not sure what to do next, i’ve done it some months ago, i believe you get a buff to destroy the firent shield, the shield has 3 layers so you need use the crystal, hit the firent and repeat. If i remember it right you can use the crystal several times in a row (up to 3?) to stack the buff.

It’s not hard once you try it, but from your report you need wait the crystal charge before using it, if you can’t see the visual effects maybe some of your graphic options are disabled.

Good luck

hmm probably there’s indeed a bug because after seeing this thread I went to that map again, I had trouble interacting with the spell suppressing crystal too.
I’ve finished the gimmicks a few months ago and I don’t remember it being like that before…

It’s just me, a level 320 Barbarian soloing the game.

I don’t have other characters either. Did have someone else in my party, but I guess they quit the game.

Yesterday one of my guildmates was trying to complete the gimmick and couldn’t either, so it’s indeed a bug. Had to go there with my Sage and save the location to open a portal for him. You should ask the same on your server, it’s the easiest way to bypass the bug.

I completed the gimmick three days ago and it’s working fine. My other post is wrong about the way to kill the firent but everything besides it is right.

It takes ~2 minutes to charge the crystal, only when the crystal ends charging there’s some visual feedback (it shines). Use the crystal to get a nitem (you can only have one at time, if you try get a second one the crystal resets), use the item to place a trap on the floor then lure the firent over it to destroy a layer of its shield. I will post some pictures later.

ahh! I see the problem now!
I forgot about the charging. my bad.
yeah you gotta wait for the crystal to shine before clicking.
I returned and tried it again today and it worked! :satisfaction:
Image from Gyazo