Tree of Savior Forum

Updater MFC - "Update Fail" each time

Date and Time :
24.4. 12:30 GMT+2
I was able to play yesterday night so about 14 hours ago and there’s been no changes to my game or computer. Didn’t even reboot.

Game Control Mode (Keyboard/Joypad/Mouse) :
Keyboard and mouse

Bug Description :
Tried to start the game normally again through Stream today but Updater MFC never even gets me to login screen anymore.

Each time it starts popping up some ToS window like this:
… for maybe 30 seconds and after that it gives this message box with “Update Fail, Please Restart” with 0% progress:

I’ve tried to following to fix it:

  • Repaired local game files through Steam. It redownloaded 5 files, didn’t help.
  • Tried launching ToS straight from it’s folder with admin rights, same problem again.
  • Ran Updater_Downloader.exe with admin rights. Successfully updates the launcher and asks to launch the client again.
  • Tried running the game again with admin rights AND through Steam again, both still having the same problem.

Steps to reproduce the issue :

  1. Try to launch the game from either it’s own folder or through Steam


  • CPU : i7 2600k @3.6Ghz
  • RAM : 16Gb
  • Graphics Card : GeForce GTX 780
  • Mainboard : Asrock Z77 Pro 3
  • Storage : 256Gb SSD
  • OS : Windows 10 Pro 64b
  • Internet Connection : 100Mb/10Mb
  • Country, Region : Finland
1 Like

Bump. Still haven’t been able to play. There goes my premium time…

Tried these as well: [quote=“STAFF_Shawn, post:1, topic:157442”]

  1. Server List Not Showing on Log-In Screen

Please download the files from the following link and copy and paste them to the following directories.

client.xml (987 Bytes)-> Steam/steamapps/common/TreeOfSavior/release

updater.config.xml (3.8 KB) -> Steam/steamapps/common/TreeOfSavior/release/patch

updater.config_en.xml (3.9 KB) -> Steam/steamapps/common/TreeOfSavior/release/patch
And this:

There never was any numbers in the release.revision.txt if that helps to solve the case.

I also just tried deleting all ToS’ game data and deleted all leftover folders manually. Redownloaded everything but still having the same problem.

1 Like

Most of the issues are caused by files ownership mismatch. Did you try running Updater_Downloader with admin rights immediately after repairing files via steam? If you launch it without admin privileges it breaks everything and you have to fix integrity via steam again. After running Updater_Downloader launch the game from steam normally.
If it doesn’t help, check your firewall (some people had issues with firewalls blocking TOS launcher after the update).

Hey and thanks for trying to help jabo_nogaems!

Just tried this again a few times with and without adding the 11460 in release.revision.txt before running check’s file check and it always leads to the same problem. Steam’s file check seems to empty the release.revision.txt file each time, is it correct as the instructions speak of replacing some currrent text there?

About my firewall, it’s not too strict either and adding both the client and updater downloader there didn’t help.

My release.revision.txt has the following contents


So apparently the instructions are outdated. Not sure if following it can be of any help.

Probably not ur case, but I have problems like this when I’m using a VPN. I can’t explain why, as other times I can login fine while using the same VPN system.

Tried a few ways with setting this 11533 as well but didn’t help.

About VPNs, I’m not using such.

1 Like

Bump. I’m still unable to play.

1 Like

Reinstalled today again without help but after multiple reboots and Steam restarts it starts again. Case solved but I’m guessing it was some sort of Steam related bug?

1 Like

Well, it started happening again. But now apparently each time I have played the game and I’m trying to re-open it.

The error is still the game: “Update Fail, Please Restart” and only restarting my whole computer seems to fix it. Not reinstalling/downloading the game or restarting Steam.

Edit: Apparently even relogging with windows account doesn’t help. It’s only the full reboot that fixes this for one gaming session.

Is there a fix for this? SAME PROBLEM.. Always need to restart my pc Because of this update fail please restart error… The same happens to me… im starting to get tired of needing restart every single time… i restart my pc at least 5 times in 10 hour gaming session… SEARCH the whole internet for SOLUTIONS. NO ANSWERS… consider the caps as highligts.