Tree of Savior Forum

Im just want play this game

Hi there,

apologies that you are experiencing troubles with installing the game.
Have you done as the message has instructed by uninstalling the game then deleting the folder afterwards and freshly installing it?

From experience on a good internet connection the game does not take longer than 30 minutes to fully be playable, thus suggesting your internet might be not as suitable due to the 4 hours stated. Have you got a way of obtaining a more substantial connection?

yeah I follow that message after uninstall im delete all data tos…and install again 16gb in my country 4 hours its pretty fast…im playing apex,bdo,dota 2,payday etc never have problem like this…

looks like you launched the game at maintenance time when you finished downloading it.

really…what a fcking joke this game…

Look, I get it you are frustrated but I am not entirely convinced it’s the games fault at this stage.
Re-download it and do a clean install, perhaps you got some corrupted files due to your internet connection being poor.

Ultimately, if you think that it’s not working might be worth trying on another device/downloading it externally and transferring the files then/etc.

If there is a will there is a way but swearing and being a complete pain to deal with never helped anyone.

yeah this gimme frustrated with this game…u know im download black dessert online, dota 2,cs go,apex legend, etc…theres no problem like this ■■■■ and im 2x reinstall this stupid game didnt solved either…like fck wtf wrong with this game dude…

The game has maintenance once per week. It was in the news on the front page.

Have you tried running it as administrator?
What are your pc specs? What’s your internet connection like? Can you provide a screenshot of any errors? And lastly what exactly is the issue?

Again, nobody else has reported any issues since this morning’s maintenance with technical issues so let’s dive in and see if we can troubleshoot you somehow. Answer the above and then we’ll take it from there. Also stop swearing it’s unbecoming.

here my spec

And have you tried getting into the game yet?
Any errors?

too much error …enough bro im reinstall this game 3x still cant play omg…I follow
instructions gm but still not solved

First, can you explain what happens when you try to play? Any error windows appear? If so, can you post?

first "Failed to download files…’
and second im fixed that “list server doesn’t exist like my girlfriend” and u can see the post gm reply…im follow that instructions but still didn’t fixed…and I try 3x reinstall this game but still cant play…this first time for me with this stupid problem…in other my game like bdo,apex,dota2,csgo,payday2 didn’t have problem like this Shiet


Ok, did you try to check the integrity of game files? (Open the library > right click on the game name > click properties > in the window that opens click on the Local Files tab > click Verify the integrity of the game files …)

If it doesn’t work, try this:

And try this, too (the fist item of the list - Server List Not Showing on Log-In Screen):

I was at my father’s place this weekend and just for fun I downloaded ToS on his antique computer. Took me 5 minutes to download, launch, patch and play.

When I installed the game in early 2017, it took me… 36 hours to have it running! Moral of the story: a good IC is all you need.

If there’s an issue for you, just ask here it’ll probably be faster. Just explain in details your problem. Seems like the download was not complete or the patches not properly applied.

This is what turned away most new players right at the gates.
This is one of the biggest factors why there were barely any new players coming.

I had this problem when I first joined the game (March 2019? or April). So many things to fix before even launching the game for the first time. My 2 other friends who were supposed to come with me straight up moved on to better games like MHW when the launch failed for a 2nd or 3rd time.

It was good that I had someone with a complete install to copy the files from (I tried to tell my friends who left to copy, but they already said they lost interest).

Looking back at it now if it was a newbie who was trying out the game for the first time and didn’t have anyone to help them. they would have walked away (Why would a newbie who hasn’t even tried the game put up with 1 to 10 to 30 hours of troubleshooting). Barely any other steam game does this. Most games are download and play in 2019.

It kinda makes you wonder how much of the playerbase was squandered right at the beginning. The next generation of players who would keep the economy growing never made it to the starting line. IMC really ■■■■■■ the game over from bottom to top.

We are sorry for the late reply.

We were investigating this issue since we saw this post, but it requires a bit more time.

We are terribly sorry.

We assumed you are a newcomer by looking at the title of the post, but we searched the access history with your linked steam account just in case. And we could not find the previous log-in history with the linked steam account of your forum account.

And We did not receive any tickets related to this kind of issue recently.

Judging by those reasons, it could be the location problem. Where are you logging in from? If you are logging in from the regional locked countries such as South Korea, Japan, Taiwan, a similar problem could occur.

yeah I very agree with u …honestly this first time for me get stupid problem like this and didn’t solved when I redownload for 4 times…this game like basically u need a friend for data back up and u can play…not a game u can download everywhere and u can play