Tree of Savior Forum

I'm guessing this goes here.. UI BUG

Here are the issues I ran in today after getting home. I was playing earlier today without issue and logged off. When I came home to play again and opened up the client and it was in another language. I closed the client and opened it back up and this time it came up and all the buttons said “No Data” followed by a string of numbers.

I have since reinstalled… twice… It didn’t fix the issue.


Have you tried the Verify Integrity of Game Cache option of Steam? Right-click on the game’s title in your library, click on Properties, click on the Local Files tab and finally click on Verify Integrity of Game Cache.

This allows Steam to validate the game and re-acquire lost files.

Yep, did that twice, have reinstalled it a couple of times now as well. Neither fixed the issue.

You might have the same problem as here. Try IMC’s solution

Nope… I found what it was. Game has defaulted to Korean for some reason… even after reinstalling it. It fixed it mostly but not completely. I still have a “No Data” thing under where it says the price. Can see the price itself just has No Data and some gibberish by it.

try to open your user.xml file in release folder, you can open it with notepad.

There, look for the Config line.
Then look for the Language parameter.
If it’s set to Language=“kr”, change it to Language=“English”
Also, look inside your languageData folder if there’s an English folder inside.

It might look like this

If none of this work extract this file inside your release folder.
It’s my release folder files so it might load a pre-made one.