Tree of Savior Forum

Game Keeps Crashing

Please fill in as much as you can :

Date and Time : 2016-04-01

Game Control Mode (Keyboard/Joypad/Mouse) : Xbox One Wireless Gamepad

Bug Description :
I just log in, and started attacking. It even happens if I were to idle for a few minutes.

** My drivers are all up to date. Currently using steam to re-verify the game, and have the game download the updates.

Steps to reproduce the issue :
A. Log in and attack some monster.
B. Log in and do nothing

Screenshots / Video :


  • CPU : Intel i5 4570
  • RAM : G.SKILL Ripjaws X 16GB 1600Mhz
  • Graphics Card : ASUS GeForce GTX 760 Directcu II OC 2GB
  • Mainboard : Gigabyte H97-D3H
  • Storage : Intel 730 Series 240GB SSD (OS & Drivers), WD Black 500GB 7200RPM (Programs and Games)
  • OS : Windows 7 (64 bits)
  • Internet Connection : 30Mbps/5Mbps Cable Internet
  • Country, Region : Canada, Ontario

Unfortunately the game is known to crash for some players who use Xbox One gamepads. This is a compatibility issue our dev team is currently working on.

Also, note that the mouse will not work properly if you are using a controller as your main input device.

If you try and launch the game without the gamepad, does it launch smoothly?

I have yesterday more than 4 crashes and i dont use a gamepad.

My game has been working perfectly fine with an Xbox One controller. Been using it the entire time. I’m on Windows 7 so I didn’t have the driver update on the controller like the Windows 10 people did. However now the game has suddenly froze up. I tried to relaunch the game which everything seemed to be fine up until I went to pick the character and channel to log in. I picked the character, and picked the lowest load channel and clicked Start Game. It begins to Enter and then if flashes up “Cannot Connect” and kicks me back out to the server screen.

It’s not the controller causing this either. I’ve unhooked the controller and tried another… I’ve even tried without the controller and just tried to log in to use keyboard and mouse. Neither of these resolved it. I believe it to be an issue between the software client and the servers.

I uninstall the game and re-downloaded the game. The Xbox One Wireless Controller was the cause for the crash. Using my F710 controller on my desktop, I do not face the same problem.