Tree of Savior Forum

Access to Varena server is temporarily restricted for new players

Access to Teslai server is temporarily restricted for new players.
Please check our announcement on the official forums or Steam community for more details.

Cant access Teslai server pls help.

Sorry, they just said, as you quoted, that new players can’t access it.

If you’ve purchased any of the DLCs before they got taken down but still can’t get in to Telsiai, send IMC support a ticket.

Otherwise, your only option is the new F2P SEA server Varena.

It is just as it says.

facing the same problem here…any solution?

@villaflorlorenze @paulyap531 facepalm sigh.

Varena should be FREE access to all…

But the notice says “Access to TELSIAI server is temporarily restricted for new players” whenever we try to connect to VARENA…

someone fix it please! it’s been hours already!


@Biskee I think he was saying that whenever he tries to enter [SEA]Varena server, got an error saying we are entering [SEA]Telsiai instead because I’m facing the same problem as well

1 Like

Ok thanks for clearing that up. Makes sense now.

Again, might be best to send IMC support a ticket as it seems the team is too busy right now to check the forums.

Also, keep an eye on the server status in the TOS website homepage.

If you can get through other servers like Klapedia and Orsha then it might be that only the Varena server is being temporarily closed. Could be an emergency maintenance.

I’m having the same issue too.

have this issue too, can’t access Varena for some reason. still no fix for this?

TONS of tickets have been sent and there’s still no reply from the moderators


same here as well I got the same issue </3

Same here, yesterday was fine, only later at night got this message.

I have the same problem. anyone got it fixed? :frowning:

Same here , got this problem.

same for me, its been 8hours now still no solution :sob:

1 Like

gg for me too, :frowning:

mine too… cant connect to varena server

Still can’t connect… has that stupid TELSAI STUFF DOING ON!! SUPREME BUMP!!!

i can connect now. :smiley: